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GvSIG_A - Présentation du logiciel 
 
 
 
 
 
 
GvSIG est un logiciel permettant d’exploiter un Système d’Information Géographique (SIG). 
 
Un logiciel SIG permet l’acquisition, le stockage, la mise à jour, la manipulation, et le 
traitement de données géographiques. De plus, il permet de faire de la cartographie et de 
l’analyse spatiale de façon précise en fonction de l’échelle désirée. 
 
Le principe directeur d’un SIG est le suivant : nous avons d’un coté les données géométriques 
et de l’autre les données attributaires. Ces données sont stockées sous format numérique et 
organisées par couches. 
 
GvSIG est sous licence libre (GNUGPL) téléchargeable en français sur le site www.gvsig.org. 
Vous trouverez d'autres logiciels libres en géomatique tel que QuantumGIS, OpenJump, Udig, 
Grass... 
 
 
 
 
Liste des fiches : 

 

GvSIG_A01 - Utilisation et possibilités du logiciel 

GvSIG_A02 - Environnement du logiciel 

GvSIG_A03 - Le gestionnaire de projet et le projet GVP 

 

 
 



F. Guerreiro 
Mise à jour : Janvier 2012 – cc by-nc-nd 2.0 

2

GvSIG_A01 - Utilisation et possibilités du logiciel 
 
 
 
GvSIG est un logiciel SIG (Système d’Information Géographique) open source 
multiplateformes (Windows, MacOS X, Linux) basé sur le langage Java qui permet les 
personnalisations spécifiques. Son interface ressemble à celle du logiciel ArcView 3.x, pour 
les utilisateurs de cette version antérieure de la société ESRI. 
GvSIG Respecte les normes de l’OGC (http://www.opengeospatial.org/). Il est associé avec 
une norme de métadonnées respectant la norme européenne ISO 19115. 
 

Outre les fonctionnalités de base que l’on retrouve dans les SIG, comme la saisie, l’édition, la 
consultation, l’interrogation et la mise en forme de données géographiques, on retrouve le 
principe des extensions, destinées à ajouter des fonctionnalités à la version de base. 
L’utilisateur a la possibilité de développer ses propres extensions en Java. 
 

Fonctionnalités présentes dans le logiciel (non exhaustives) : 
- Exploitation de diverses sources de données telles que les serveurs distants (SQL 

Server, MySQL, POSTGIS, Oracle (avec l’extension GeoDB) et via les protocoles 
WMS, WFS, JDBC, WCS, ArcIMS), les fichiers tabulaires (txt), les bases de données, 
les imports et exports (Dxf, gml, shape, postgis)… 

- Création et édition de données 
- Edition des attributs et des objets géographiques (avec gestion topologique telle que le 

snaping ou fusion des limites) 
- Géoréférencement des fichiers raster au format Tif, JPG, Gif ou Png. 
- Gestion et reprojections (systèmes de projection européens et mondiaux intégrés au 

logiciel selon les codes EPSG – www.epsg.org) 
- Géotraitements (buffer, intersection, union, jointures spatiales, moyennes…) et 

sélections 
- Exploitation graphique (histogrammes…) des données attributaires 
- Cartographies thématiques (qualitatives ou quantitatives) et production cartographique 

(échelle dynamique, nord, légende) 
- Représentation 3D (avec le module d’extension correspondant)… 

 
Voici une liste des modules disponibles par défaut à l’installation de GvSIG 1.11 : 
 

 
 

Les modules grisés sont installés par défaut. 
 
Certains de ces modules sont disponibles manuellement pour les versions antérieures de 
GvSIG, sur le site officiel (www.gvsig.org). 
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GvSIG_A02 - Environnement du logiciel 
 
 
GvSIG est classiquement composé d’une barre des menus et de barres d’outils variées selon 
les besoins, en fonction des fenêtres que l’on a ouvertes. 
 
C’est à partir de la barre des menus que l’on accède à la plupart des fonctions de GvSIG. 
 

 
 

Le menu Fichier (nouveau, ouvrir, fermer ou enregistrer des projets…) est classique des 
logiciels couramment utilisés. Le projet est le fichier dans lequel les travaux seront 
enregistrés. Reportez-vous à la fiche A03 pour en savoir plus sur le projet. 
 
Le menu Afficher  permet d’afficher trois fenêtres différentes : 

- La console   a pour fonction d’afficher l’information relative aux actions entamées. 
Les erreurs, informations et validations d’actions sont reportées dans cette fenêtre. 

- Le gestionnaire de projets, fenêtre principale qui permet notamment de gérer les 
Vues (les données géographiques et leurs attributs), Tables (les données 
exclusivement sémantiques), Cartes (les mises en pages). D’autres éléments peuvent 
y être gérés tels que les Vues 3D sous réserve d’installer les Extensions 
correspondantes. Reportez vous à la fiche A03 qui détaille le gestionnaire de projets. 

- Le Gestionnaire de connexion à des serveurs de BD géographiques qui active les 
connexions aux BDD PostGis JDBC, HSQLDB et MySQL JDBC. 

 
Le menu Fenêtre permet d’accéder aux Préférences  du logiciel ainsi que de réorganiser 
les fenêtres actives et ouvertes. 
A partir du menu Fenêtre> Préférences, vous obtiendrez, en plus du choix de langue du 
logiciel, ou des paramètres d’affichages divers, les Extensions du logiciel installées sur votre 
ordinateur. Ceci permet notamment de les activer ou les désactiver. Des extensions 
supplémentaires sont disponibles, par exemple sur le site officiel www.gvsig.org. 
 
 
Le menu Aide, renferme des éléments d’explications de fonctions, triées par catégories. 
 

L’intérêt non négligeable du menu Table  →  est de pouvoir 
conserver les formats de valeurs lors de l’import d’un fichier DBF (équivalent à une table 
Excel, mais qui enregistre les valeurs et non les calculs). Évite, par exemple, de tronquer des 
champs ou de remplacer des accents par des caractères inappropriés !) 
 
Certains menus n’apparaissent que lorsque la fenêtre correspondante est ouverte et active 
(menu Fenêtre). Ceci concerne les menus tels que , ,  lors de l’ouverture de la 
fenêtre vue ; le menu  si une table est ouverte ; le menu  lors de l’activation 
d’une fenêtre carte… 
Ces menus permettent de réaliser les actions sur les fenêtres actives au premier plan (le menu 
Carte ne peut pas être affiché en même temps que le menu Vue par exemple..). 
 
Les barres d’outils apparaissent selon la fenêtre active. Les outils sont identiques à ceux que 
l’on trouve dans les menus. Les barres d’outils sont détaillées dans leurs fiches respectives. 

 Cette barre d’outils, que l’on retrouve quelque soit la vue, reprend 
respectivement la Console (informations, erreurs..) et les Préférences logiciel. 
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GvSIG_A03 - Le gestionnaire de projet et le projet GVP 
 
 
 
La mise en forme des fenêtres Vue, Table, Carte, l’ordre de superposition des couches, le 
choix des styles pour les objets cartographiques, le positionnement des étiquettes, la légende 
etc. sont autant d'opérations qu'il est intéressant de sauvegarder pour ne pas avoir à les 
reproduire à chaque ouverture de GvSIG. Le projet de travail (Projet GvSIG) vous permet de 
sauvegarder une session de travail. 
Le gestionnaire de projet est toujours accessible depuis le menu Afficher > Gestionnaire de 
projet . 
 

Liste des
Fenêtres disponibles
Possibilité de créer plusieurs fenêtres par type
(Par exemple, plusieurs fenêtres de mise en page différentes)

Menus de la fenêtre sélectionnée
Les propriétés de chaque fenêtre
se gèrent depuis ce menu

Types de fenêtres par défaut
-Vue
-Table
-Carte

Fenêtres
supplémentaires
Par ajout
d’extensions
spécifiques

Gestionnaire de projets

 
 
Pour enregistrer l’état d’avancement de votre travail dans un projet, allez dans le menu 
Fichier >Enregistrer un projet . 
 
Le projet est un fichier unique contrairement à une couche, composée de plusieurs fichiers. Il 
ne contient pas de données géographiques. Il renferme simplement une série d'instructions qui 
est donnée à GvSIG et qui précise les couches géographiques utilisées dans la session, l’état 
des fenêtres Vue (Fiche B02), Carte (Fiche F01) ou Table (Fiche B04), la mise en forme des 
objets, etc. Le projet peut-être assimilé à une macro des logiciels bureautiques. 
Ainsi il peut exister un grand nombre de projets qui utilisent les mêmes couches de données 
dans des mises en forme différentes. 
Cependant, comme le document contient des instructions sur les couches à utiliser, il est 
indispensable de préserver ces couches telles que lors de l'enregistrement du projet. Si, par 
exemple, une couche est déplacée ou renommée et que le projet n'est pas réenregistré pour 
prendre en compte la modification, ce dernier ne s'ouvrira pas. 
 
Si votre projet et toutes vos couches sont rassemblés dans un même dossier global, vous 
pouvez désormais déplacer ce dossier, à condition d’avoir décoché la case  
dans les propriétés du projet ! 
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GvSIG B - Gestion des couches 
 
 
 
 
 
 
La gestion des couches est essentielle pour bien démarrer l’apprentissage du logiciel. 
Bien comprendre comment s’organisent les couches les unes par rapport aux autres et 
comment s’organise l’articulation entre la donnée géographique et la table attributaire qui lui 
est associée, est la base de la compréhension des logiciels SIG. 
 
 
Une gestion approximative des couches peut générer de nombreux problèmes d’analyse, 
affichage… 
 

 
 
 
Liste des fiches : 

 

GvSIG_B01 - Ouverture et fermeture d’une couche 

GvSIG_B02 - La gestion visuelle des couches : La fenêtre Vue 

GvSIG_B03 - Barres d’outils de la fenêtre Vue 

GvSIG_B04 - Affichage des données attributaires à l’écran 

GvSIG_B05 - Connaître et modifier la projection d’une couche 
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GvSIG_B01 - Ouverture et fermeture d’une couche 
 
 
 
Affichez la fenêtre Vue sur laquelle vous travaillez (Fiche B02), allez dans le menu Vue 
>Ajouter une couche (  ou ). Choisissez le fichier que vous voulez ouvrir 
dans la boite de dialogue : sous l’onglet Fichier, cliquez sur le bouton Ajouter . 
Attention : Renseignez le système de projection de la couche à ouvrir s’il est différent de 
celui de la Vue (Fiche B05) !! 
 

Ouvrir un fichier

2 – Choisir le type de fichier à ajouter
Types par défaut :

• Vecteurs 
•SHP, DGN, DWG, DXF
•GML, KML

• Rasters (IMAGE, RAW)

1 - Parcourir les données

3 – Modifier le 
système de projection
(si différent de la vue)

Liste des couches à ajouter

Ouvrir un fichier
Courant 

 
 
Pour les images raster géoréférencées, les informations de localisation géographique sont 
chargées automatiquement lorsque vous ouvrez l’image (Raster Driver). 
Pour ouvrir une image NON calée et la caler à partir de GvSIG, reportez-vous à la fiche G02. 
 
Le choix du Type de fichier lors du parcours des fichiers influe sur le type de fichiers visibles 
dans le dossier courant ! Exemple : si vous choisissez Fichiers de type : ‘gvSIG shp Driver’, 
les fichiers de type DXF ne seront alors pas visibles pour l’ouverture. 
 
 
Pour supprimer une couche ACTIVE, faites un clic droit sur son nom, puis Supprimer la 
couche. Cette action retire la couche du logiciel mais ne la supprime pas de l’ordinateur. 
 
Vous pouvez rendre actives plusieurs couches en maintenant Ctrl enfoncé lorsque vous 
cliquez sur le nom d’une couche. 
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GvSIG_B02 - La gestion visuelle des couches : La fenêtre Vue 
 
 
 
La fenêtre Vue gère les vues créés. Ces vues sont l’organisation visuelle de la superposition des 
couches. C’est de cette fenêtre que l’on gère toute l’analyse spatiale et le requêtage sur les couches. En 
ouvrant la fenêtre Vue, les menus Couche, Table et Vue sont accessibles (fiche B03). 
 

Liste des différentes vues créées

Propriétés de la fenêtre vue

Propriétés de la vue sélectionnée

Projection de la vue
La projection de la vue se règle en tout premier li eu, avant d’ajouter des couches!!

Attention!!
La projection par défaut de chaque nouveau projet e st ED50 / UTM 30N (EPSG 23030)

Projection

Unités cartographiques

Nom de la vue

NB : La gestion des projections peut être améliorée à l’a ide d’un module : CRS Module; cf. 
Fiche des extensions utiles  

 

La fenêtre Vue s’ouvre à partir du Gestionnaire de projet (fiche A03). 
 

Affichage de la vue (Ouvrir)

La fenêtre vue

Sources : IGN - GéoFla®/ RGC®

Accès au menu d’une couche
Par clic droit sur le
nom de la couche

Ordre de
superposition
des couches

Couche
Active
(en surbrillance)

Symbologie
de la couche

Affichage des données

Couche Visible
(cochée)

 
 

La superposition des couches se gère par glissement du nom des couches les uns sur les autres. 
Accédez aux Propriétés, par un clic droit sur le nom de la couche pour gérer les Symboles, 
l’ Étiquetage et l’onglet Hyperlien, en plus de l’onglet Général pour le niveau de zoom et les alias. 
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GvSIG_B03 - Barres d’outils de la fenêtre Vue 
 
 
Lorsqu’une vue est active (au premier plan), les menus suivants sont disponibles : 
 

- menu Couche : pour l’export de la couche ou l’affichage 
des attributs de la couche active (en surbrillance), 

 
 
- menu Table : pour effectuer les requêtes attributaires, 

 
 

- menu Vue : reprend l’ensemble des opérations géographiques disponibles pour les 
couches de la vue courante (analyse spatiale, création de couche…). 

   
 
Beaucoup d’outils issus des menus se retrouvent dans les barres d’outils. Vous retrouverez ici 
les barres essentielles afin de vous familiariser avec les symboles raccourcis les plus utilisés. 
 
GvSIG 1.9 à 1.11        Versions antérieurs 

Ajouter des données géographiques (couches) 
 
 

Outils de zoom (respectivement revenir au 
zoom précédent, zoom avant, zoom arrière, 
zoom général, zoom avant constant, zoom 
arrière constant) 
Outils de déplacements rapides 
(respectivement gestionnaire de zoom 
prédéfinis, déplacement sur la carte) 
 

Outil d’interrogation géographique (respectivement 
information de la zone cliquée, calcul de distance, 
calcul de surface, et hyperlien) 
 

Actions qui se réalisent sur la couche ACTIVE (nom sélectionné en gras dans la table des 
matières -gauche- dans la fenêtre vue) : 
 

 
Afficher les attributs de la couche active 
 

Sélectionner des entités géographiques 
(respectivement : simple, rectangulaire, par 
polygone dessiné, en fonction d’une autre 
couche, et inverser la sélection 
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Versions antérieures 
à GvSIG 1.9 

GvSIG_B04 - Affichage des données attributaires à l’écran 
 
 
 
Dans la fenêtre Vue (fiche B02), à partir du menu Couche, sélectionnez Voir la table des 
attributs  ou appuyez sur  pour afficher les données attributaires d’une couche. La couche 
doit être active. Observez les données puis fermez la table  lorsque vous avez fini. 
 

Remarque : la sélection 
d’une entité sur la carte 
avec l’outil sélection 
implique la sélection des 
données associées dans 
la table attributaire (et 
inversement).

Lien entre les données graphiques et attributaires

Une fois la table ouverte,
Elle reste disponible à partir du 
gestionnaire de projet , dans la 
fenêtre Table .

Fenêtre Table
Vue active

Table attributaire

 
 

Lorsque l’on sélectionne une entité sur la vue, à l’aide de l’outil sélection , la ligne 
correspondante est sélectionnée dans la table (et inversement). 
Toute table attributaire ouverte à partir de la Vue est ensuite accessible depuis le gestionnaire 
de projet, sous l’onglet Table, avec les tables sans entités associées (DBF, CSV..). 
 

Les outils du menu Table (disponibles lorsqu’une table attributaire est ouverte) : 
Les outils suivants sont disponibles depuis la barre d’outils : 
 

Actions sur les champs : 
Il est possible de sélectionner plusieurs champs à l’aide de  
la touche Ctrl . ,  et  sont actifs lorsqu’une colonne est 
sélectionnée (bouton ‘nom de champ’ appuyé).  est 
disponible uniquement pour les champs numériques. 
 

Actions sur les lignes : 
Pour sélectionner plusieurs lignes, appuyer sur Ctrl . Pour 
sélectionner un groupe de lignes, faites glisser le curseur ou 
appuyez sur Maj . 

 et  sont actifs lors d’une sélection de 
ligne (en jaune). 

 

Actions d’analyse attributaire : 
 correspond à la sélection par attributs ! 
 et  permettent respectivement les jointures et les mises en 

relations attributaires. 
 engage un tableau récapitulatif personnalisable à souhait ! 
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GvSIG_B05 - Connaître et modifier la projection d’une couche 
 
 
 
La projection d’une couche est très importante. Vous devez, pour travailler proprement sur 
vos couches, œuvrer dans un système de projection unique dans la mesure du possible. Ceci 
évite les erreurs lors de calculs d’analyse spatiale, ne serait-ce que pour calculer des distances, 
ou pour croiser des couches. Evitez de modifier la projection dans la mesure du possible, car 
les passages multiples d’une projection à une autre génèrent des déformations sur les entités. 
Les projections dans GvSIG sont exprimées selon les codes EPSG1. 
 
Sous GvSig, la projection se gère en amont du travail, pour ces éléments : 

- Projection de la vue : 
Au moment de la création de la Vue, vous devez indiquer la projection de cette vue (cf. fiche 
B02). Ceci aura une influence sur l’affichage de toutes les couches ; en effet, voici la même 
couche affichée selon deux vues dont les systèmes de projection sont différents : 

 

Voici la même couche, départements de France en Lambert 
93, affichée selon une vue en L93 à gauche, et selon une 
vue en WGS 84 à droite. 
 

Source des images : IGN - GéoFla® 
 

- Projection des couches : 
Vous devez impérativement connaître le système de projection de chaque couche ouverte. 
Par défaut, GvSIG applique la projection définie pour la vue ; si la projection de la couche est 
différente de celle de la vue, vous devez renseigner cette projection lors de l’ajout (cf. fiche 
B01). Le renseignement erroné d’un système de projection peut induire des erreurs visibles 
(cf. exemple ci-dessous) ou non (calculs de surfaces, croisements de couches…) 

Sur cet exemple, j’ai volontairement indiqué à GvSIG que la couche de la France 
est en NTF - Lambert Centre France, alors qu’elle est en L93, comme la vue sur 
laquelle je travaillais : la conséquence est ici très visible, puisque la couche est 
située 4 à 5000km au nord des autres données, déformée et désorientée. On 
retrouve aisément la Bretagne au nord-est, le Nord pas de Calais au sud-est et 
l’Alsace au nord-ouest… 

 
Modifier une projection 
 

À partir de la vue courante, allez dans 
le menu Vue> Boite à outils de 
géotraitement pour ensuite lancer 
Reprojeter. 
Modifiez ensuite la projection selon 
son code EPSG. 
La reprojection créé une nouvelle 
couche.  
 
 
Pour les transformations NTF/Lambert ↔ 
RGF Lambert93, préférez l’utilisation du 
logiciel gratuit Circé téléchargeable sur le site 
de l’IGN (www.ign.fr) ou GDAL/ OGR. 

                                                 
1 Codes EPSG utiles à connaître (http://www.epsg.org/) utilisés dans les logiciels : 
2154 : RGF93 Lambert 93 ;  4326 : WGS84 world geographic 2D ; 
27561 : NTF Lambert Nord France ;  27562 : NTF Lambert Centre France ;  27563 : NTF Lambert Sud France ;  27564 : NTF Lambert Corse ; 
27571 : NTF Lambert zone I ; 27572 : NTF Lambert zone II ;  27573 : NTF Lambert zone III ;  27574 : NTF Lambert zone IV ; 

Couche en sortie!

Couche initiale à reprojeter

Modifier la projection

Nombres d’entités sélectionnées dans la couche initiale
Possibilité de ne reprojeter qu’une partie de la couche

Code EPSG de projection initiale de la couche

Code EPSG de la projection en sortie

Chemin du résultat de la couche reprojetée
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GvSIG_C - Structure des couches 
 
 
 
 
 
 
La création d’une couche se fait en trois temps. 
Il faut d’abord créer la structure de la couche et bien réfléchir aux informations qu’elle doit 
contenir. Il faut ensuite créer les entités graphiques. Enfin, il faut remplir la table attributaire 
en respectant bien le lien avec la donnée géographique. 
 
 
 
 
Liste des fiches : 

 

GvSIG_C01 - Création d’une couche 

GvSIG_C02 - Éditer des données 

GvSIG_C03 - Création de champs attributaires 

GvSIG_C04 - Création d’objets graphiques 

GvSIG_C05 - Modification d’objets graphiques 

GvSIG_C06 - Modification d’objets sémantiques 
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GvSIG_C01 - Création d’une couche 
 
 
 
La création d’une couche doit être précédée d’une étape de réflexion sur la modélisation du 
phénomène à intégrer dans le SIG. Il s’agit d’un aspect fondamental qui permettra une 
utilisation rationnelle et aisée du SIG. Une étape à ne pas négliger ! 
 
Tous les objets d’une même couche doivent être du même type géographique (point, ligne 
ou polygone). 
 
Chaque objet géographique stocké dans une couche est doté d’un certain nombre d’attributs 
(ou champs), qui sont définis ultérieurement, lors de la modification de la structure de la 
couche. 
 
 
A partir du menu Vue (cf. Fiche B03), choisissez Nouvelle couche. Vous pouvez alors créer 
une couche ERSI (SHP), AutoCad (DXF) ou PostGis. 
Quelque soit le type de fichier créé, la procédure s’exécute en trois étapes : 

1 - Choisir le nom et le type d’entités à créer (point, ligne ou polygone). 
2 - Créer les champs attributaires ou colonnes (cf. fiche C02). 
3 - Indiquer l’emplacement, le nom du fichier (!! Le système de projection est celui 
de la vue !!). 

 
Création d’une couche Alias de couche

Type d’entités de la couche

Type
de la

donnée

Nom
de la

colonne

Ajouter ou supprimer
des champs

2 - Champs

1 - Entités

3 - Enregistrement

Chemin
d’enregistrement
de la couche

Projection de la
nouvelle couche
⇒ Projection
de la vue!

 
 
Lorsque la couche est crée, elle est automatiquement ajoutée à la Vue courante en mode 
édition ; elle est donc modifiable ! Son nom est noté en rouge dans la table des matières de la 
vue (partie gauche de la vue). Pour créer des entités, reportez-vous à la fiche C04, et pour 
remplir les champs correspondants aux entités créées, reportez-vous à la fiche C06.  
NB. : Pour arrêter l’édition d’une couche, choisissez Terminer l’édition  par clic-droit sur le 
nom de la couche ou à partir du menu Couche. 
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GvSIG_C02 - Éditer des données 
 
 
 
Toute action de modification sur une couche, que ce soit au niveau de sa structure, des entités 
ou de la table attributaire se fait selon un rite précis sous GvSIG. 
 
 
Éditer une couche 
La couche à éditer doit être active, c’est-à-dire surlignée en noir (en gras). 
Dans la fenêtre Vue, commencez l’édition à partir du menu Couche >Commencer l’édition, 
ou par clic-droit sur le nom de la couche. 
Le nom de la couche est alors en rouge, l’édition de la structure, des entités ou de la table 
attributaire peut commencer. 

Le curseur prend alors une autre forme , des menus et des barres d’outils d’éditions sont 
alors disponibles. 
Pour éditer la table attributaire de la couche, procédez de la même façon puis ouvrez la table 
attributaire ! 
 
 
 
Arrêter l’édition 
Pour arrêter l’édition, procédez de la même façon, menu Couche> Terminer l’édition. Ceci a 
pour effet d’arrêter l’édition de la couche ACTIVE (en gras rouge !). 
 

N’hésitez pas à afficher et utiliser l’Historique des commandes  qui permet de visualiser 
les actions d’édition précédentes et qui peut les annuler si besoin. 
 
NB. : Lorsque vous terminez l’édition d’une couche ou d’une table, GvSig vous demande 
automatiquement si vous voulez enregistrer les modifications apportées. Ceci est très utile en 
cas de d’erreur ou de mauvaise manipulation. 
 

Il est possible de commencer l’édition de 
plusieurs couches en même temps ; il reste 
cependant recommandé de ne faire qu’une seule 
chose à la fois ! 
La fenêtre ci-dessous est un exemple de message 
lors de la fermeture du logiciel ; certaines couches 
ont été modifiées, d’autres sont simplement en 
mode « édition » ; pensez donc à toujours arrêter 
une édition avant d’en entreprendre une autre !!! 
Il est impossible d’éditer une couche qui a un 
système de projection différent de celui utilisé 
dans la vue. 

 
 
 
Éditer une table attributaire qui ne possède pas d’entités (dbf, csv…) 
Ouvrez la table à éditer depuis la fenêtre Table (fiche B04 si besoin). 
Dans le menu Table, choisissez Commencer l’édition. 
Pour terminer l’édition, retournez dans ce menu Table, et choisissez Terminer l’édition  qui 
remplace Commencer l’édition. 
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GvSIG_C03 - Création de champs attributaires 
 
 
 
La modification de la structure de la table attributaire d’une couche est à éviter dans la mesure 
du possible, car l’ajout ou le retrait de champs peut ‘perturber’ la table. Il est donc important 
de vérifier les données attributaires après ce type d’intervention. 
GvSIG gère différents types d’attributs : texte, entier, réel double, date et booléen. 
 
 
Modifier les champs d’une couche 
Commencez l’édition de la couche ou de la table (fiche C02), puis affichez la table. 
Dans le menu Table, choisissez Modifier structure de table. 
A partir de ce menu, vous pouvez (comme le présente le dessin ci-dessous) : 

- Modifier ou supprimer un champ existant 
- Créer un nouveau champ 

Gestion des champs attributaires

Renommer un champ
Supprimer un champ
Agit sur le champ
sélectionné en gris 

Type de champ (texte, entier…)

Propriétés du champ
(longueur de texte, du nombre, 
nombre de décimales…)

Nom du champ

 
 
Lors de la création du champ, vous devez définir tous les éléments constitutifs de ce champ en 
fonction de son utilisation ultérieure. 
Le Type : une variable ‘nombre’ peut être créée en ‘texte’ pour des raisons d’analyse (codes 
INSEE, numéros de départements…), alors que d’autres seront utilisés en ‘réel double’ pour 
la symbologie (surface) ou ‘entier’ (population…). 
La Longueur : pas besoin d’une longueur de 50 pour les données cadrées (INSEE, 
surface…), par contre pour des noms de communes, cela semble indiqué. 
La précision sera fonction de la donnée. Exemple : Une surface théorique calculée avec le 
SIG n’implique pas que vous deviez laisser 8 chiffres après la virgule ! 
 
D’une manière générale, pensez à tous les champs, leur nom et leur structure, avant de 
commencer le travail, et évitez les manipulations ultérieures de la structure des tables 
attributaires. 
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GvSIG_C04 - Création d’objets graphiques 
 
 
 
Ajoutez la couche à la Vue active (fiche B01) et rendez-la éditable (fiche C02) ou créez une 
nouvelle couche (fiche C01). 
Dans la fenêtre Vue, un menu Géométrie apparaît ; parcourez-le et choisissez Insérer : 

 

 
: Création de points 
 
 

: Création de lignes 

 
: Polygone libre / Polyligne 
 

 
  Polygones réguliers 
 
 

 
 

La barre d’outils Insert, qui reprend les outils ci-dessus apparaît 
automatiquement lors de l’édition : 
 

Outils particuliers 
Les multipoints  permettent la création de points multipartie (plusieurs points correspondent à 
une même entrée/ligne dans la table). 
Des polygones indépendants peuvent devenir multipartie à l’aide de l’outil Joindre . 
 
Attention  : L’outil polyligne , permet aussi de créer des polygones libres lorsque vous 
travaillez sur une couche de POLYGONES, tel que le fait le polygone auto .  
 

Numérisation 
Choisissez l’outil et commencez la numérisation. 
Les objets de création disponibles lors de l’édition dépendent du type d’entité de la couche ! 
Par un clic droit pendant la construction, vous pouvez Terminer  ou Annuler  la construction 
en cours. Vous pouvez aussi, lors de création de lignes ou polygones, créer des Arcs. 
Lorsque vous avez terminé la création de vos entités, choisissez de Terminer l’édition (fiche 
C02) et sauvegarder le travail. 
NB. : Pour créer des entités parfaitement synchrones (limite commune, nœuds communs…) 
reportez-vous au snapping de la fiche C05. 
 

Suppression d’une entité 
L’opération consiste à sélectionner une entité sur la couche et à la supprimer. Une fois qu’elle 
est sélectionnée avec la flèche de sélection  de la barre d’outils Modification  ou du menu 
Géométrie, appuyez sur la touche Suppr du clavier pour la supprimer. 
La couche doit évidemment être modifiable. 
 

Pour supprimer plusieurs enregistrements, utilisez ctrl  pour les sélectionner à partir de la 
table, utilisez la touche Maj  pour les sélectionner à partir de la couche graphique. 
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GvSIG_C05 - Modification d’objets graphiques 
 
 
 
La modification d’une limite requiert que la couche soit modifiable (fiche C02). 
 
 
Capture/Snapping 
A partir d’un clic-droit sur le nom de la couche modifiable, choisissez les Propriétés de 
l’édition  ; vous pouvez alors afficher l’environnement de capture. 
Vous pouvez choisir la Tolérance de capture dans l’onglet Édition  ainsi que les couches qui 
entrent dans la capture : Les sommets des couches sont ainsi aimantés à l’approche du curseur 
lors d’un déplacement ou la création de nœuds. 
En plus de pouvoir afficher et paramétrer une Grille , et de Limiter la taille du cache, vous 
pouvez également définir le Snapping : Cette fonction va vous permettre de placer les points/ 
nœuds exactement les uns au dessus des autres ou suivant les limites d’autres entités. 
Les outils de superposition des nœuds  et de superposition d’un nœud le long d’une 
ligne  sont les plus utilisés et indispensables pour la gestion de la topologie lors de l’édition 
d’une couche. 
 
 
Sélection 
A l’aide de l’outil Sélectionner  du menu Géométrie, cliquez sur l’entité que vous voulez 
modifier (plusieurs sélections en maintenant Ctrl ). Vous pouvez faire une sélection complexe 

 (menus encore plus complexes par clic-droit sur la vue avec l’outil). Les nœuds de la 
couche sont visibles et numérotés par ordre de création. 
 
 
Modification 
Les outils de modification sont disponibles depuis le menu Géométrie> Modifer ou 
directement à partir de la barre d’outils Modifications (ci-dessous) qui apparaît 
automatiquement lors d’une édition de couche : 
 

 
 

Modifiez les nœuds avec l’outil Éditer les sommets  ; Faites un clic-droit à un endroit pour 
ajouter ou supprimer un nœud. Déplacez un nœud avec l’outil Sélectionner . 
 
L’ensemble de l’entité peut être modifiée ; vous pouvez ainsi Déplacer , Copier , faire la 
Symétrie  la Rotation  ou changer d’Échelle  d’une entité. Choisissez l’outil puis 
cliquez sur l’entité à modifier. 
 
Il es possible d’effectuer des actions sur une entité préalablement sélectionnée . 
Vous pouvez ainsi Étirer   plusieurs nœuds d’une entité en les sélectionnant avec l’outil 
puis en les déplaçant. 
Supprimez une partie intérieure d’un polygone avec l’outil Polygone Interne . 
Scindez une entité en plusieurs entités avec l’outil Dégrouper entités , et inversement, 
fusionnez plusieurs entités sélectionnées avec l’outil Joindre . 
 
Quittez l’éditeur, en enregistrant les modifications une fois le travail fini ! 
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GvSIG_C06 - Modification d’objets sémantiques 
 
La modification des données attributaires se fait en concordance avec les objets graphiques 
correspondants. 
Lors d’une modification (ou d’une création) des données attributaires, il faut sélectionner 
l’entité sur la carte pour savoir à quelle ligne de la table correspond cette entité. 
 

La sélection de l’objet sur la carte se matérialise par un jaune fluo  (couleur modifiable dans 
les Propriétés du Gestionnaire de projet – cf. fiche A03). Dans la table correspondante, la 
sélection se remarque de la même façon (). La sélection de l’objet entraîne la sélection de la 
ligne dans la table, et inversement. 
 
Calcul d’un champ 
Pour mettre une table attributaire à jour, Commencer l’édition (cf. fiche C02 si besoin), 
affichez la table  puis changez les données en cliquant sur un enregistrement à changer. 
Lorsque vous avez fini, Terminez l’édition . 
 

Pour calculer ou « recalculer » des données d’une colonne entière (champ) 
vous devez dans un premier temps sélectionner cette colonne en cliquant 
sur le bouton entête du champ : 
Calculer ensuite les valeurs avec l’outil Expression  du menu Colonne ou de la barre 
d’outils. Une boîte de dialogue apparaît ; vous pouvez ainsi calculer vos valeurs suivant une 
expression. Si des lignes sont sélectionnées, les mises à jour ne concerneront que ces lignes. 
 

Saisie des données attributaires
La saisie des données se fait dans la table
en fonction des éléments graphiques

Calcul de champ attributaire/ colonne
Création d’objets graphiques
La numérisation des objets se fait
à l’écran sur la couche éditable

Sources : IGN - GéoFla®

Tapez l’expression ici

ColonneColonne
àà mettre mettre àà jourjour

Colonnes de références si besoin

Fonctions de calcul

ColonneColonne
àà mettre mettre àà jourjour

 
 

Pour calculer l’aire**, tapez simplement area() dans la zone de calcul, pour les coordonnées 
en x, tapez x(). Il n’est nécessaire d’inclure les " "  dans l’expression que pour les chaines de 
caractères (texte). 
 

Il est possible d’Ajouter/ Supprimer une ligne directement sélectionnée depuis le menu 
Table. 
 
**Il est possible d’ajouter directement un champ contenant une information géographique supplémentaire selon 
le type d’entité (surface, périmètre…) à partir de l’outil Ajouter information géographique  du menu 
Couche (Penser à choisir la couche de destination dans la boîte de dialogue !). 
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GvSIG_D - Analyse spatiale 
 
 
 
 
 
 
L’analyse spatiale participe au traitement même des données à partir de requêtes spatiales 
bien définies ou d’actions qui permettent de répondre à un questionnement précis. 
Une requête est une opération qui consiste à interroger une partie de la table de données (ou 
table attributaire). 
Les requêtes peuvent porter aussi bien sur des données attributaires que sur des objets 
géographiques. 
 
 
 
Liste des fiches : 

 

GvSIG_D01 - Sélection par attributs (requête attributaire) 

GvSIG_D02 - Sélection géographique (requête géographique) 

GvSIG_D03 - Jointure attributaire/ Jointure spatiale 

GvSIG_D04 - Outils d’analyse 
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GvSIG_D01 - Sélection par attributs (requête attributaire) 
 
 
 

La sélection attributaire se fait sur une seule couche et sur un ou plusieurs attributs de cette 
couche. Depuis la fenêtre vue (fiche B02 si besoin), choisissez le menu Table> Filtre . 
 

La couche concernée par la sélection 
est la couche ACTIVE

Méthodes de 
Sélection

Choix des 
Champs Choix des 

Valeurs
connues

Requête

Sélection par attributs

11
33

22 Opérateurs 
de sélection

554 : V4 : Véérificationrification

 
 

Entrez l’expression de la sélection, appliquez la sélection désirée, et fermez la fenêtre de 
dialogue pour voir les sélections sur-brillantes en jaune fluo. Désélectionnez les entités 
sélectionnées de la couche active avec l’outil Effacer la sélection  du menu Couche. 
 

Exporter la sélection 
Vérifiez que la couche sur laquelle vous venez de réaliser la sélection soit bien active (en 
gras), choisissez le menu Couche> Exporter en…, puis le type de fichier d’export (SHP par 
défaut). Dans la boîte de dialogue, confirmez le nombre d’entités sélectionnées, déterminez le 
nom et l’endroit de la couche de sortie. 
 

Exemple 
Sélectionner tous les départements qui ont leur chef-lieu dont le X est à moins de 5100m de l’origine (attribut 
« X_CHF_LIEU ») et n’appartenant pas à la Bretagne (attribut « NOM_REGION ») dans la couche 
‘DEPARTEMENT.SHP’ affichée ci-dessous : 
 

 
 

Couche : DEPARTEMENT.SHP (à activer en gras dans la vue) 
Critères (requête) : X_CHF_LIEU <= 5097 and NOM_REGION <> 'BRETAGNE' 
X_CHF_LIEU et NOM_REGION (noms des colonnes) sont à sélectionner dans le menu champs, =, >= et And 
dans les Opérateurs. 5097 et  'BRETAGNE' peuvent être saisis directement dans Valeurs connues. 
 

NB : les valeurs en texte sont à saisir entre guillemets simples ('…'), contrairement aux nombres. 
And :"vrai" lorsque ses deux arguments (les expressions qu'il relie) sont vrais. Un enregistrement doit donc satisfaire ces deux conditions 
pour être sélectionné. 
Or  :"vrai" lorsque l'un au moins de ses arguments (les expressions qu'il relie) ou les deux sont vrais. Un enregistrement ne doit donc 
satisfaire qu'une seule de ces deux conditions pour être sélectionné. Il est aussi sélectionné s'il répond aux deux conditions. 
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GvSIG_D02 - Sélection géographique (requête géographique) 
 
 
 
Dans le menu Vue de la fenêtre Vue (fiche B03 si besoin), choisissez sélection. Une liste de 
sélections s’offre à vous pour la couche ACTIVE (en gras) : 

 

Sélectionne les entités de la couche active qui intersectent la forme créée 

 
Sélectionne les entités à une distance définie d’entités sélectionnées 
 
 
Sélections directes 
 
 
 
 
 

 
 
 

La Sélection par couche du menu Vue> Sélection, présentée ci-dessus, offre la possibilité 
de sélectionner des entités d’une couche en fonction d’entités sélectionnées d’une autre (ou la 
même) couche. La syntaxe se monte comme une simple phrase à lire. 
 

A

B

Se superposent à

Opérateurs de la sélection géographique

A
Sont contenues dans

B

Sont disjointes de

A

B

Contiennent

A

B

A

B

Touchent

+

S’intersectent avec

A

B
B

=

A

Sont identiques à

B

Croisent avec

A
B

A est la couche de référence, B est la couche active dans laquelle on sélectionne  
 

Désélectionnez les entités sélectionnées de la couche active avec l’outil Effacer la sélection 
 du menu Couche. 

 
Exemple : 
Sélectionner les éléments de la couche ‘riviere.shp’, qui intersectent le département du Nord de la couche 
‘departement.shp’ : 
Vous devez sélectionner préalablement le département du Nord dans la couche ‘departement.shp’ (A) et rendre 
la couche ‘riviere.shp’ (B) active dans la vue. 
Ensuite, dans l’interface de sélection géographique : Sélectionner dans la couche active les entités qui : 
S’intersectent avec Entités sélectionnées de la couche : departement.shp. B S’intersecte avec la sélection de 
A. 
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GvSIG_D03 - Jointure attributaire/ Jointure spatiale 
 
 
 
Jointure attributaire 
La jointure de tables est généralement utilisée pour adjoindre des attributs supplémentaires à 
la table d’une couche géographique (couche de départ). Pour joindre deux tables, le type des 
données du champ joint doit être identique entre les tables (nombres, chaînes…). 
 

Pour faire une jointure de table, une table attributaire doit être ouverte (fiche B04 si besoin). 
Dans le menu Table, choisissez Joindre . La boîte de dialogue suivante apparaît : 
 

Jointure attributaire

2 : Table jointe

1 : Table de départ
Champ de jointure
de même nature!
(texte, nombre…)

3 : Résultat

Préfixes de champs respectifs

 
 

Renseignez la table de départ (qui peut être la table d’une couche) et le champ à joindre pour 
la table. Faites de même pour la table à joindre ( !! Un champ à joindre peut porter un nom 
différent dans les tables). Ce sont les attributs de la table jointe qui viendront se greffer sur 
ceux de la table de départ. 
Ouvrez la table attributaire  de la couche géographique de base pour voir si la jointure a 
réussi. Observez pour cela les entêtes des champs, vous devez y trouver les préfixes. 
 
Exemple : 
Vous disposez d’une couche ‘comm.shp’ représentant le contour des communes ; la table attributaire de cette 
couche ne contient que le code INSEE de chaque commune (nommé IDINSEE). Vous disposez, d’autre part, 
d’une table attributaire ‘comm_attr’ (sans données graphiques) contenant le nombre d’habitants (attribut « hab ») 
et d’autres champs pour chaque code INSEE ; ce dernier s’intitule CODE sans la table. 
1. Table source : ‘Comm’ ; champ : IDINSEE  2. Table de destination ‘comm_attr’ ; champ : CODE 
 
Jointure spatiale 
Pour opérer une jointure spatiale (selon l’emplacement et la 
superposition des objets) ouvrez la Boîte à outils de 
géotraitement du menu Vue (cf. fiche D04) et choisissez la 
Jointure spatiale. 
Dans la boîte de dialogue, sélectionnez d’abord la Couche d’entrée qui contiendra les objets 
de la Couche de sortie, puis la Couche de découpage qui contiendra les attributs joints. 
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GvSIG_D04 - Outils d’analyse 
 
 
 
Les outils d’analyse sont nombreux, il convient de réfléchir à la finalité du travail avant de se 
lancer dans les modifications. Les outils d’analyses sont dans le menu Vue> Boîte à outils de 
géotraitement  : 

 
Chaque outil dispose d’une aide en anglais détaillée, et est 
composé d’une interface où il faut renseigner trois éléments : 
1.  Couche sur laquelle l’opérateur va agir (input). 
2.  Couche qui participe à l’opération (feature). 
3.  Couche résultante de l’opération 
 
Si vous avez une sélection active sur une des couches qui entre 
dans l’analyse, l’opérateur peut réaliser l’analyse uniquement sur 
celle-ci ! Il suffit de le préciser dans l’interface en cochant 
l’élément correspondant . 
 
NB : L’opération d’analyse ne se réalise que sur les couches 
ouvertes dans la vue active. 
 

 

Retrouvez ci-dessous quelques exemples d’outils les utilisés en SIG, présents dans GvSIG : 
 

Exemples d’outils d’analyse

Analyses> Cache>Découper

Analyses> Cache>Intersection
pour  assembler uniquement les portions d’entités qui 
se superposent ou à limite  commune

Analyses> Cache>Union
pour assembler  les entités qui se superposent

Analyses> Cache>DifférenceAnalyses> Proximité>Zone tampon

ou

Analyses> Regroupement>Regrouper
(fusion) Créé des entités se lon une colonne spécifiée

 
 

 
 
Remarque : Il existe d’autres outils disponible au travers d’extensions (disponible 
essentiellement à partir du site www.gvsig.com). Par exemple, l’outil SEXTANTE  
fourni à la fois des capacités d'analyse géographique vectorielles et sur les rasters. Cette 
extension met à disposition plus de 150 outils dont la géo-statistique, les indices de 
végétation, l'analyse hydrologique... Pensez à consulter le menu aide  qui détaille 
certains outils de Sextante ! 
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GvSIG_E - Analyse thématique/Sémiologie/Symbologie 
 
 
 
 
 
 
L’analyse thématique met en évidence un ou plusieurs phénomènes de la carte et participe 
grandement au rendu final d’une carte. Elle joue un rôle dans la perception de la carte par vos 
interlocuteurs. Il est donc indispensable de prendre du recul pour voir si le rendu de 
l’information est fidèle à ce que vous vouliez mettre en avant. Il est aussi indispensable que 
votre information soit claire et non noyée dans une masse d’informations inutiles. 
 
 
 
 
Liste des fiches : 

 

GvSIG_E01 - Symbologie/ Affichage simple des entités 

GvSIG_E02 - Analyse thématique/ Affichage avancé des entités 

GvSIG_E03 - Etiquetage des entités 
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GvSIG_E01 - Symbologie/ Affichage simple des entités 
 
 
 
Modifier toutes les entités d’une couche 
Cette étape est importante lors de la manipulation des données, car elle gère le rendu visuel de 
la superposition des couches. C’est dans ces propriétés que vous rendrez l’intérieur des entités 
d’une couche transparent pour voir les couches du dessous. 
 
Double-cliquez sur la couche ou faites un clic-droit pour afficher les Propriétés de la couche. 
Puis sélectionnez l’onglet Symboles. 
 
Cliquez sur sélectionner symbole à côté du rectangle du symbole pour appeler la fenêtre : 
 

Changer le figuré unique de toutes les entités de la couche

Types d’entités

Texture
Aspect
Couleur

Edition avancée
des propriétés
d’affichage

 
 
Le bouton Propriétés du Choix de symboles permet de changer plus d’options dans 
l’affichage des entités de la couche. 
 
La texture disponible est fonction du type d’entités : 

- Brush - polygones 
- Pen - lignes/ polylignes 
- Symbol - points/ multipoints 

 

La transparence de la couche se gère à l’aide d’une barre de progression . 
Cette barre est présente sous la couleur de l’entité. La transparence de chaque élément d’entité 
se fixe indépendamment (contour et fond). 
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GvSIG_E02 - Analyse thématique/ Affichage avancé des entités 
 
 
 
L’analyse thématique a pour objectif principal de mettre en forme les données que vous 
voulez faire ressortir de la carte. L’analyse thématique répond aux règles principales de la 
sémiologie graphique. Reportez-vous à ces règles pour connaître les différents types 
d’analyses et/ou méthodes de classification des données (intervalles égaux, seuils naturels, 
quantiles). 
 
Par un clic-droit de la couche, sélectionnez l’onglet Symboles des Propriétés de la couche. 
 

Dans la partie gauche de la boîte de dialogue, sélectionnez l’analyse thématique la plus 
appropriée à l’affichage de vos données. Reportez vous à l’aide et aux règles de la sémiologie 
graphique pour adapter votre analyse. 
 
Exemple 
Pour afficher un dégradé de couleur pour la superficie d’une couche de polygones (on admet qu’il y ait un champ 
‘SQKM’ correspondant à la superficie dans la table attributaire de la couche en question) : 
Dans la partie gauche de l’onglet Apparence, sélectionnez quantités puis Intervalles. 
Dans la partie Champ à classer, au centre de la boîte de dialogue, choisissez ‘SQKM’ (surface calculée) dans le 
menu déroulant. Vous pouvez changer les couleurs des plages en double-cliquant dessus, ainsi que le nombre de 
classes et le mode de calcul des classes, puis OK .  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Utilisez l’affichage par Catégories pour les valeurs qualitatives et les Quantités pour les 
valeurs quantitatives et ordonnées ; de la même façon, procédez à un affichage de deux 
données numériques indépendantes en variant le Champ de symbole et le Champ de 
couleur de l’affichage par Attributs multiples . 
 
 

Remarque : Les couches sont enregistrées en shapefile (*.shp). Il est possible de 
sauvegarder les symbologies produites avec Enregistrer une légende (*.glv ou 
*.sld). Pour l’appliquer à d’autres couches, cliquez sur le bouton Charger une 
légende de l’onglet Symboles. 

Classement 
des valeurs 

Importation de la 
symbologie  

Plages et 
couleurs de 
classement 

Etiquettes 
de légende 

Type d’analyse 
thématique 

Exemple de 
représentation du 
type d’analyse 
thématique choisi 
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GvSIG_E03 - Etiquetage/ Annotation des entités 
 
 
 
Double-cliquez sur le nom de la couche et sélectionnez l’onglet Etiquetage. 
 

Assurez-vous que l’étiquetage des entités est actif en cochant la case correspondante 
. 

Assurez-vous que le champ de l’étiquette est bien celui qui contient les étiquettes que vous 
voulez voir afficher ! 

 

L’étiquetage se paramètre par le Champ de 
l’étiquette (apparait sur la carte finale), la Police, 
la Hauteur et la Couleur; les deux derniers 
peuvent faire appel à un champ de la table). 
Attention : Pour obtenir un affichage correct, il 
convient de travailler en Unité Millimètres  sur 
Paramètres de l’imprimante ! 
 

 
Enregistrer l’étiquetage dans une couche : Couche d’annotation 
A partir du menu Couche> Exporter en…> Annotations, vous pouvez créer une couche 
(shape - SHP) qui ne possèderait que les étiquettes d’une couche, sans les entités. 
Lancez l’outil Annotations, en vous assurant que la couche à étiqueter est active (en gras) et 
déterminez ensuite tous les paramètres de l’étiquette, en trois étapes : 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
L’avantage de la couche d’annotation est que vous pouvez la placer au dessus des autres 
couches, le désavantage étant que la police n’est plus paramétrable. 

 

Une fois la couche d’annotations créée, elle se manipule 
de la même façon qu’on couche classique. Il est possible 
de modifier certaines de ses caractéristiques à partir de 
ses Propriétés (clic droit sur le nom de la couche). 

 

Attention ! Si vous fermez une couche d’annotation : 
- Vous pouvez l’ouvrir comme un fichier shape classique, le logiciel le reconnait telle 

une couche de points (fiche B01 si besoin) 
- Vous pouvez l’ouvrir comme un fichier d’annotation à partir du menu Vue> Ajouter 

une couche géographique, puis choisir l’onglet Annotations dans la fenêtre de 
dialogue qui s’ouvre. 

1 – Champ 
d’annotation 

2 – caractéristiques 
d’annotation 

3 – enregistrement 
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GvSIG_F - Mise en page 
 
 
 
 
 
 
La mise en page est l’étape finale du travail. 
Elle consiste à mettre tous les éléments indispensables à une carte. 
La carte doit contenir impérativement : 
Une légende, un titre, l’orientation, l’échelle, les sources, le nom et la date de réalisation. 
 
Les logos et mentions légales ne sont pas superflus, ainsi qu’un texte explicatif pour éviter 
toute mauvaise interprétation de la carte produite. 
 
 
 
Liste des fiches : 

 

GvSIG_F01 - Création d’une mise en page 

GvSIG_F02 - Création d’une légende 

GvSIG_F03 - Éléments d’une mise en page 

GvSIG_F04 - Exportation de la mise en page 
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GvSIG_F01 - Création d’une mise en page 
 
 
 
 
La création d’une mise en page permet d’éditer une carte complète pour l’imprimer ou 
l’exporter. 
Ouvrez ou créez une fenêtre Carte à partir du Gestionnaire de projets (fiche A03 si besoin) 
 
Si nécessaire, changez le nom de vos couches en double-cliquant sur chacune d’elles pour 
ouvrir les propriétés de la couche, sous l’onglet général. Vous pouvez changer les couleurs 
et les symboles de tous les éléments sous l’onglet Symboles (fiche E02 et E03). 

 
Sélectionnez la mise en page dans le menu carte> Préparer la page 
et changez la mise en page de paysage (horizontal) vers portrait  
(vertical) si besoin. 
 

Le cœur de carte, à savoir la Vue , s’ajoute en premier lieu à partir 
de ce menu Carte> Insérer. 
 

La barre d’outils Carte est disponible lorsqu’une fenêtre Carte est 
active (au premier plan). 
 

Pour ajouter les éléments indispensables à votre carte comme le titre 
(Texte ), la Orientation , l’Échelle , la Légende  (fiche 
F02) ou un logo (Image ), allez dans Ce menu Carte> Insérer et 
sélectionnez l’item désiré. 

 
 

Lorsque la carte est terminée, allez dans le menu Fichier, pour Exporter en PDF ou 
Exporter en PS (fiche F04). 
N’oubliez pas d’Enregistrer le projet au fur et à mesure de votre travail (fiche A03 si 
besoin).. 
 
Vous pouvez vous déplacer sur la page à partir de la barre spécifique de Mise en Page 
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GvSIG_F02 - Création d’une légende 
 
 
 
Une commande spécifique existe pour créer une légende décrivant toutes les informations 
contenues dans la carte. Menu Carte> Insérer> Légende… . Pour cela, il faut bien 
évidemment se trouver sur une fenêtre Carte. 
L’ajout d’une légende n’est possible que lorsqu’une vue au moins a été ajoutée à la fenêtre 
Carte ! 
 

Création d’une légende

1 – Choix de la vue 
correspondant à la légende 2 – Choix des couches 

figurant dans la légende

3 – Police de la légende 4 – Rotation et qualité
de présentation

 
 

Lorsque vous avez terminé, une nouvelle fenêtre Légende apparaît, configurée. 
 
La légende sur la fenêtre Carte est dynamique ; elle se remet à jour lorsque vous modifiez les 
éléments de la couche (nom, figurés…). Il est cependant conseillé de ne créer la légende 
qu’après avoir finalisé tous les éléments nécessaires à la carte. 
 
Éléments de légende et Police 
La police de la légende et les éléments qui doivent y figurer sont à modifier dans les 
Propriétés de la Légende elle-même par un double-clic ou clic droit sur celle-ci. 
 
Libellés des éléments de légende 
Pour gérer les libellés de la légende, reportez-vous aux Propriétés de la couche concernée. En 
effet, sous l’onglet Général, vous pouvez modifier le nom de la couche, et sous l’onglet 
Étiquetages, vous pouvez gérer les Etiquettes de chaque classe. 
C’est sous l’onglet Apparence des Propriétés de la couche que vous pouvez modifier les 
libellés de la symbologie des éléments. 
 
NB. : Les éléments de la légende sont organisés par défaut selon l’ordre d’empilement des 
couches. Celui-ci ne correspond bien souvent pas aux règles de mise en page d’une légende 
(élément principal de la carte en premier, regroupement des éléments de la légende en 
fonction de leur type…). Pour permettre la modification de l’organisation de ces éléments, 
vous devez les Dissocier , à partir du menu Carte> Éléments graphiques. 
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GvSIG_F03 - Éléments d’une mise en page 
 
 
 
Les éléments de la mise en page s’ajoutent à partir du menu Insérer, lorsque l’Affichage 
Mode mise en page est actif. 

 

 

Ajouter une vue : elle s’ajoute en 
premier lieu à partir du menu Carte> 
Insérer> Vue , 
 

Ajouter du texte : titre, commentaires... 
Pour ajouter du texte cliquez  puis sur la carte à l’endroit désiré. 
Vous pouvez par la suite modifier le texte (taille, police, orientation, 
habillage, etc.) en double-cliquant sur celui-ci. 
 

Ajouter une orientation :  
Pour ajouter une flèche de nord il vous faut utiliser l’outil  
correspondant. Par défaut GvSIG vous offre déjà un large choix de 
flèches, mais vous pouvez importer les vôtres si besoin. 
 

Ajouter une échelle graphique : 
L’échelle graphique  est 
paramétrable : 

 

 
 
 
 
 
 
Sélectionner et déplacer les éléments : 
Tous les outils utilisables sur les objets géographiques dans les fenêtres cartes sont utilisables 
sur les objets de la mise en page. Ainsi vous pouvez sélectionner un objet : , pour le déplacer 
en gardant le clic-souris actif ; supprimer un élément en pressant la touche suppr du clavier ou 

. 
Pour déplacer, grouper, ou dissocier des objets, les mettre au premier ou dernier plan, un clic 
droit dessus ou un outil de la barre suivante permet l’action : 

 
 

Pour redimensionner un objet il faut le sélectionner puis faire glisser les "poignées" situées 
aux coins du rectangle englobant l’objet. 
 

Disposer les objets : 
Il est possible de disposer les objets par rapport à la page (aligner à gauche, aligner à droite, 

centrer). Pour cela il faut sélectionner l’objet puis utiliser les 
outils de la barre concernée. 
De la même façon on peut disposer un ensemble d’objets les 
uns par rapport aux autres en les sélectionnant tous puis en 
utilisant le même menu Aligner . Ce menu persistant est 
disponible à partir de Carte> Éléments graphiques. 

Sélectionner la vue à ajouter 

1- Choisir la vue associée à l’échelle 

2- Choisir l’aspect de l’échelle 

3- Choisir l’unité 
 

4- Choisir la largeur de l’échelle 
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GvSIG_F04 - Exportation de la mise en page 
 
 
 
Lorsque la mise en page est terminée, vous avez le choix de l’imprimer (menu Carte> 
Imprimer ) ou d’exporter cette mise en page (menu Ficher> Exporter en PDF ou Ficher> 
Exporter en PS). 
Lorsque vous exécutez cette action d’imprimer, vous imprimez la fenêtre active, donc 
n’oubliez pas de vous positionner sur la fenêtre Carte, si elle est la fenêtre que vous désirez 
imprimer ! 
 

Avant l’export final, il est indispensable d’observer la carte en taille réelle  car le logiciel 
n’adapte pas toujours visuellement les éléments de la carte à l’échelle. De la même façon, 
avant l’impression, l’étiquetage peut sembler totalement démesuré par rapport à la carte ; des 
essais d’impression peuvent être utiles. 
 
Exemple d’impression : 

   
Fenêtre carte    Résultat de l’export direct de la fenêtre ci-contre 

Il est à noté sur cet exemple que GvSIG ne respecte pas les règles de limites de classes qui se suivent et qu’il conviendrait de les modifier. 
 

Remarques sur le format d’export de la carte : 
- Il est possible d’exporter simplement la fenêtre Vue, lorsque celle-ci est active (au 

premier plan), à partir du menu Vue> Exporter> Image. Vous obtenez alors le cœur 
de carte exploitable en PNG, JPG ou BMP dans un logiciel de publication ou dessin 
classique (PAO/DAO). 

- A partir du menu Fichier vous pouvez Exporter en pdf la mise en page créée. 
Pour d’autres formats d’exports vous pouvez installer un petit logiciel d’impression en 
images diverses tel PDFCreator, disponible gratuitement sur Internet. 

 

D’une manière générale, il est préférable d’exporter en PNG lorsque votre carte ne contient 
que des vecteurs et en JPG dès qu’il y a des images ou des rasters sur votre carte. 
Exemple : la qualité de l’image doit être plus importante pour une image qui doit être projetée en présentation (PowerPoint) que pour une 
image insérée dans le texte d’un rapport d’étude (Word). 
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GvSIG_G - Intégration de données externes 
 
 
 
 
 
 
 
 
 
 
 
Liste des fiches : 

 

GvSIG_G01 - Ouverture/Export de données tabulaires (txt, csv, dbf) 

GvSIG_G02 - Géoréférencement d’images : Données rasters 

GvSIG_G03 - Ouverture de protocoles Internet - WebServices 

GvSIG_G04 - Import de fichier interchangeable (MIF/ MID)  

 
 
 



F. Guerreiro 
Mise à jour : Janvier 2012 – cc by-nc-nd 2.0 

33

GvSIG_G01 - Ouverture/Export de données tabulaires (txt, csv, dbf) 
 
 
 
Les données tabulaires sont des données attributaires ; elles ne possèdent pas de données 
géographiques (pas d’entités !). 
GvSIG vous offre la possibilité d’ouvrir directement des fichiers DBF et des fichiers CSV2. 
Ouvrez le fichier à partir du Gestionnaire de projets (fiche A03), fenêtre Table, choisissez 
Nouvel Amer. 
Pour ouvrir un fichier XLS : sous Microsoft Excel3, enregistrez-le sous DBF4, puis ouvrez le 
DBF4 sous GvSIG. 
Pour ouvrir un fichier TXT : sous un éditeur de texte (bloc note sous Windows), assurez-vous 
que le fichier texte est formaté (organisé) de la même manière qu’un fichier CSV (cf. Note de 
bas de page), puis enregistrez le résultat avec l’extension CVS au lieu de TXT. 
 
Une fois un fichier ouvert, vous pouvez ensuite gérer la table comme une table attributaire de 
couche géographique classique (fiche B04). 
 
Attention : Les fichiers CSV sont en lecture seule. Vous pouvez exporter ces données (ainsi 
que toute table ouverte) dans deux formats (DBF ou XLS) à partir du menu Table> Exporter, 
lorsque la table en question est ouvert et au premier plan. 
 
 
Acquérir des données géographiques à partir de tables attributaires : 
Certaines données ne présentent pas d’objets géographiques mais ceux ci peuvent être construits si on 
connaît leur localisation en X et en Y. C’est notamment le cas de points acquis sur le terrain à l’aide de 
systèmes de positionnement par satellites type GPS. Dans la plupart des cas les GPS permettent de 
récupérer des fichiers de points au format ASCII (format texte) si les données ne sont pas directement 
transférables au logiciel SIG. 
 

La présence de coordonnées X et Y dans les champs de la table va nous permettre de créer 
pour chaque ligne du tableau un point avec les coordonnées correspondantes. 
Pour cela, placez-vous sur une fenêtre Vue active, puis choisissez le menu Vue> Créer une 
couche de points à partir de la table attributaire  pour obtenir la fenêtre ci-dessous : 
 

 
 

Choisissez la table à partir de laquelle vous voulez créer une couche, puis renseignez le 
champ X et le Y. 
N’oubliez pas que les coordonnées présentes dans la table, doivent impérativement être dans 
le même système de projection que la fenêtre Vue dans laquelle vous travaillez ! 

                                                 
2 Le fichier CSV est éditable/créable avec un éditeur de texte. La première ligne doit contenir les champs des 
colonnes, séparés par « ; » (un point-virgule), les lignes suivantes les données, séparées aussi par « ; ». 
3 Attention depuis Excel 2010, il n’est plus possible d’exporter un XLS en DBF ; je vous conseille l’utilisation 
de LibreOffice ! 
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GvSIG_G02 - Géoréférencement d’images : Données rasters 
 
 
 
Vous n’avez pas besoin d’ouvrir l’image avant de la géoréférencer. 

Utilisez la barre  (disponible par défaut dans la vue 
active) pour commencer le géoréférencement/ 
Dans cette barre, vous disposez d’une catégorie , puis d’un outil , et du nom d’une 
couche de la vue. Choisissez (avec la fleche ) la catégorie , puis 
l’outil . Cliquez ensuite sur cet outil  pour lancer la fenêtre suivante 
(options que vous retrouvez plus tard dans le géoréférencement avec l’outil Option ) : 
 

Géoréférencement d’une image

Cas 1 : vous connaissez les
coordonnées des points de calage
Cas 2 : vous allez vous baser sur
une des vues pour caler l’image

Fichier (image) à caler

Répertoire de travail temporaire
Laisser par défaut

Type de transformation**

Type de géoréférencement*

Taille du pixel, par défaut le logiciel
Reconnait la taille.

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Vue de référence Image à référencer 

Outils de déplacement 
sur les vues 

Points de calage 

ZOOM 
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dans la fenêtre Points de calage, pour ajouter un lien, cliquez d’abord sur Nouvel amer . 
Par défaut, toutes les coordonnées sont à zéro. 
Lors du géoréférencement, vous pouvez modifier un amer en vous plaçant dessus (la ligne est 
alors surlignée), centrer dessus dans toutes les fenêtres , le supprimer , ou supprimer 
tous les amers . Vous pouvez aussi charger  ou exporter  des points d’amer. 
 
*Type de géoréférencement 
Cas 1 : Vous connaissez les coordonnées des points à géoréférencer 
Rentrez-les manuellement dans World X  et World Y , puis recherchez le point entré dans la 
zone de droite (image à référencer). Cliquez le point dans la vue ou dans le Contrôle de 
zoom. Les coordonnées « image » (pixels) s’ajoutent dans Image X et Image Y. 
 

Cas 2 : Vous utilisez la vue de géoréférencement pour caler l’image 
Pointez d’abord la zone de gauche (image de référence) et cliquez le point dans la Vue de 
géoréférencement ou dans le Contrôle de zoom. Les World X  et World Y  se remplissent 
automatiquement avec les coordonnées, dans le système de projection de la vue en question ! 
Recherchez ensuite ce même point dans la zone de droite (image à référencer). Cliquez le 
point dans la vue ou dans le Contrôle de zoom. Les coordonnées « image » (pixels) 
s’ajoutent automatiquement dans Image X et Image Y. 
 
**Type de transformation 
On utilise une transformation affine lorsque l’image à référencé est dans la même projection 
que l’image de référence (3 à 4 points suffisent). On utilise les transformations polynomiales 
lorsque les déformations sont importantes (cartes napoléoniennes…). Vous avez besoin d’un 
minimum de trois points pour une transformation polynomiale de premier ordre, six pour une 
transformation de second ordre et dix pour une transformation de troisième ordre.  

Remarque : Un grand nombre de points n’améliore par forcément la qualité du résultat, préférez donc des 
points près de chaque angle de l’image à référencer et quelques points au centre. N’alignez pas vos points. 

 
Vérification et enregistrement du géoréférencement 
Avant d’enregistrer d’enregistrer le calage, vous pouvez Tester géoréférencement  pour 
apprécier le calage global, puis cliquer sur Fin du test  pour stopper ce test. 

 
 

Lors de la création des points, vous obtenez une erreur RMS pour chaque point (erreur 
relative de chaque point par rapport aux autres) ainsi qu’un RMS global. 

 
 

Lorsque celui-ci vous emble acceptable, vous pouvez Finaliser le géoréférencement . 
L’information géographique est alors stockée dans un fichier « *.rmf~ », « *.jpgw » 3ou autre, portant le même 
nom que l’image. 

 

 

Notes de versions antérieures à GvSIG 1.9 : 
Le géoréférencement s’obtient en ajoutant une couche et sélectionnant Géoréférencer 
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GvSIG_G03 - Ouverture de protocoles Internet - WebServices 
 
 
 
 
Les protocoles Internet cartographiques sont des services qui diffuses (gratuitement ou non), 
des cartes et données disponibles au travers du logiciel SIG. 
L’avantage certain de ces services est de ne pas devoir stocker les données (souvent très 
lourdes) sur l’ordinateur, et de pouvoir superposer ces services aux données locales dont vous 
disposez dans votre SIG. 
 
GvSIG offre la possibilité d’en afficher plusieurs d’entre eux (WCS, WMS, WFS et ArcIMS). 
Pour accéder à ces services, il suffit de : 

1- Entrer l’adresse Internet du service 
2- Choisir les données dont on a besoin 
3- Paramétrer le rendu des données 

 

Connexion aux protocoles de services
1 - Connexion

2 – Choix des données
disponibles
sur le service

3 – Format de restitution

Format d’image

Projection

Choix des couches

 
 
De nombreux services sont accessibles directement dans GvSIG et vous en trouverez 
facilement sur Internet. 
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GvSIG_G04 - Import de fichier interchangeable (MIF/ MID) 
 
 
 
Pour importer un fichier MIF/MID dans GvSIG (et le transformer en SHP), vous devez 
installer FWTools, disponible à l’adresse http://fwtools.maptools.org/ (FWTools et OpenEV 
sont deux logiciels libres et gratuits sous licence GPL). 
Ouvrez le logiciel OpenEV depuis votre poste de travail (Démarrer> Programmes> 
FWTools> OpenEV). 
 
Dans OpenEV, choisissez le menu File> Open, puis parcourez vos données jusqu’au fichier 
MIF (format interchangeable) que vous voulez transformer en SHP (shape) comme le montre 
l’illustration ci-dessous : 
 

 
 
 
 

 
 
Le logiciel ouvre une fenêtre avec les couches 
disponibles dans le MIF (cf. image ci-contre). 
Sélectionnez la couche que vous voulez 
convertir, puis cliquez sur accepte Accept. 
 
Choisissez ensuite le menu File> Save vector 
layer, choisissez le chemin d’accès et rentrez 
un nom de couche. 
 

Le logiciel enregistre le fichier 
automatiquement en SHAPE (*.shp) sous le 
nom de fichier que vous avez choisi. 
 
 

 
Ouvrez enfin le fichier en SHP dans GvSIG (fiche B01 si besoin). 


