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Fiches d’aide à QGIS 
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Validité pour toutes les versions 3.x 
 
 

Site officiel du logiciel : 
https://www.qgis.org (Équipe de développement de QGIS (2018). Système d’information 
géographique QGIS. Open Source Geospatial Foundation Project. http://qgis.osgeo.org) 

 
Utilisation des fiches 

 
Ces fiches sont créées dans un but de formation ou d’autoformation avec la version 3.10.3 du 
logiciel. 
Le document est réutilisable dans son intégralité, ou fiche par fiche si besoin, selon la licence 
cc-by-sa-4.0. 
L’utilisation de ces fiches est simple (orientée utilisateur final), il faut comprendre le sommaire 
pour retrouver aisément les manipulations du logiciel. 
 
Les captures d’écran sont issues du logiciel QGIS (GNU – www.qgis.org), associées à des 
données personnelles. Symboles utilisés dans les fiches : 

• Point d’information 
• Point d’attention 
• Manipulation du logiciel 
• Nouveauté du logiciel depuis la dernière version LTR (3.4) 

 
Bugs rencontrés lors de la création des fiches et contournements : 

• Connexions https pour le GeoJSON par défaut : dans le menu "Préférences > Options", 
onglet "Système", ajouter la variable d'environnement GDAL_HTTP_UNSAFESSL et 
pour valeur YES, puis redémarrer QGIS. 
 
 
 

 

 
http://creativecommons.org/licenses/by-sa/4.0/ 
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QGIS_A - Présentation du logiciel 
 
 
 
 
QGIS est un logiciel permettant d’exploiter un Système d’Information Géographique (SIG). 
 
Un logiciel SIG permet l’acquisition, le stockage, la mise à jour, la manipulation, et le 
traitement de données géographiques. De plus, il permet de faire de la cartographie et de 
l’analyse spatiale de façon précise en fonction de l’échelle désirée. 
 
Le principe directeur d’un SIG est le suivant : nous avons d’un côté les données géométriques 
et de l’autre les données attributaires, liées à ces données géométriques. Ces données sont 
stockées sous format numérique et organisées par couches. 
 
QGIS est distribué sous licence publique générale GNU téléchargeable en français sur le site 
https://www.qgis.org. Il existe d'autres logiciels libres en géomatique tel que GvSIG, 
OpenJump, Udig, Grass... 
 
QGIS installe des logiciels tiers qui possèdent leur propre licence. Liste des logiciels installés : 

1. QGIS 
2. Oracle Instant Client 
3. MrSID Raster Plugin for GDAL 
4. ECW Raster Plugin for GDAL 
5. SZIP compression library 

D’autres composantes nécessaire à des utilisations spécifiques sont installées telles que : 
- GRASS (orienté traitements d’images),  
- SAGA (orienté hydrologie, analyse de paysages, 
-  QT (interfaces graphiques),  

Sous licence GNU-GPL  
- Python (langage de programmation) sous licence libre Opensource (compatible GPL) 
- … 

 
 
Liste des fiches : 

QGIS_A01 - Utilisation et possibilités du logiciel 

QGIS_A02 - Environnement du logiciel 

QGIS_A03 - Interface et barres d’outils 

QGIS_A04 - Le projet QGZ 
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QGIS_A01 - Utilisation et possibilités du logiciel 
 
 
QGIS est un logiciel SIG (Système d’Information Géographique) open source multiplateformes 
(Windows, MacOS, Linux). 
QGIS Respecte les normes de l’OGC (http://www.opengeospatial.org/).  
QGIS a vu ses débuts comme logiciel de cartographie et s’est développé au fil des années pour 
s’imposer parmi les logiciels SIG libres les plus performants. 
 

Outre les fonctionnalités de base que l’on retrouve dans les SIG, comme la saisie, l’édition, la 
consultation, l’interrogation et la mise en forme de données géographiques, on retrouve le 
principe des extensions, destinées à ajouter des fonctionnalités à la version de base. L’utilisateur 
a la possibilité de développer ses propres extensions en Python. 
 

Fonctionnalités présentes dans le logiciel par le biais d’extensions ou non (non exhaustives) : 
- Exploitation de diverses sources de données telles que les serveurs distants (SQLITE, 

MySQL, POSTGIS, ORACLE, ODBC ESRI database… et via les protocoles WM(T)S, 
WFS(-T), WCS, SFS, GML), les fichiers tabulaires (txt), les bases de données, les 
imports et exports (TAB, Dxf, gml, shape, PostGIS, e00, gtx, kml) … 

- Création et édition de données 
- Edition des attributs et des objets géographiques (avec gestion topologique telle que le 

snaping ou fusion des limites) 
- Géoréférencement des fichiers raster au format Tif, JPG, Gif, ASC, IMG, ECW ou 

Png… 
- Gestion et reprojections (systèmes de projection européens et mondiaux intégrés au 

logiciel selon les codes EPSG – www.epsg.org) 
- Géotraitements (buffer/tampon, intersection, union, jointures spatiales, moyennes…) et 

sélections 
- Exploitation graphique (histogrammes…) des données attributaires 
- Cartographies thématiques (qualitatives ou quantitatives) et production cartographique 

(échelle dynamique, nord, légende, atlas…) 
 

Voici la liste des 11 modules disponibles par défaut à l’installation de 3.8 : 
 

 
 

Les modules précédés d’une encoche sont activés par défaut. Les extensions en ROUGE ont 
été mal installées (raisons techniques). 
La liste est disponible depuis le menu Extension > Installer/Gérer les extensions :  
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QGIS_A02 - Environnement du logiciel 
 
 
 
QGIS est classiquement composé d’une barre des menus et de barres d’outils variées selon les 
besoins. 
 
C’est à partir de la barre des menus que l’on accède à la plupart des fonctions de QGIS. 
 

 
 

Du fait de son historique à orientation cartographique, QGIS possède des menus orientés vers 
cette dernière, et des menus complémentaires, traitant plus spécifiquement des SIG. 
La plupart des actions de ces menus sont repris sous formes de barres d’outils (cf. fiche A03). 
 
Le menu Projet (nouveau, ouvrir, fermer ou enregistrer des projets…) est classique des 
logiciels couramment utilisés. Le projet est le fichier dans lequel les travaux seront enregistrés. 
Se reporter à la fiche A04 pour en savoir plus sur le projet. 
 
Le menu Editer (copier, coller, ajouter ou supprimer…) permet d’accéder à toutes les 
fonctionnalités d’édition d’entités géographiques fiche C04 et C05). 
 
Le menu Vue permet d’accéder aux outils de déplacement et d’interrogation des données 
géographiques. 
 
Le menu Couche gère la possibilité d’ajouter ou retirer des couches (vecteurs, rasters ou WMS) 
du projet, ainsi que les actions classiques de gestion des couches (voir les attributs des couches 
ou activer l’édition de couche…). 
Le menu Couche, accessible par sa barre d’outils qui reprend les actions, est aussi partiellement 
accessible depuis un clic-droit sur le nom de la couche. 
Les outils relatifs à l’accès aux informations (cf. barre d’outils Couche> Accéder aux 
informations de la fiche A03 si besoins) ont une action sur la couche ACTIVE donc surlignée 
en gris ! 
 
Le menu Préférences referme l’accès aux propriétés du projet et celles logiciel en général. 
 
A partir du menu Extension, les extensions du logiciel installées par défaut sur l’ordinateur 
sont listées. Ceci permet notamment de les activer ou les désactiver. Des extensions 
supplémentaires sont disponibles, par exemple sur le site https://plugins.qgis.org/plugins/ . 
 
Le menu Vecteur intègre des fonctionnalités de géotraitement sur les couches vectorielles, alors 
que le menu Raster intègre les fonctionnalités de traitement des données sur les rasters. 
 
Les menus Base de données, Internet et Traitements viennent compléter les menus des 
versions précédentes ; le premier reprend les diverses extensions (BD Manager, Evis, …) qui 
offrent des options différentes de connexions aux bases de données ; le second regroupe les 
outils liés à la publication Web des données, alors que Traitements permet d’utiliser la boite à 
outils de géotraitements, pour une accessibilité rapide (GRASS, SAGA…). 
 
Le menu Aide renferme des éléments d’aide complémentaires et de l’Internet si besoin. 
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QGIS_A03 - Interface et barres d’outils  
 

Interface 
QGIS est à l’image de 
nombreux logiciels SIG, 
composé : 
- D’une partie supérieure avec les 

Menus et Barres d’outils, 
- D’une partie gauche qui contient 

les noms des couches ouvertes, 
- D’une partie centrale pour 

l’affichage géométrique des 
entités des couches, 

- D’une partie supplémentaire à 
gauche depuis le menu Vue 
>Panneaux.  

 
Barres d’outils 
Les barres d’outils reprennent les fonctionnalités présentes dans les menus. 

Barre d’outils Projet
Gestion des projets

Barres d’outils

Barre d’outils Vue
Evoluer sur la vue

Barre d’outils Attributs
Accéder aux informations de la couche ACTIVE!

Barre d’outils Couche
Ajouter des informations (données)

 

Barres d’outils supplémentaires 
   

Créer des entités

Modifier des entités

Barres d’outils Éditer : Modifier des entités Autres barres d’outils et Extensions

Barre d’outil Grass

Barre d’outils Raster

Barres d’outils d’Extensions : Exemple Grass

Menu (Extensions> Grass)

L’extension doit être

préalablement activée
depuis le menu Extensions

Menus (Fiche A02) 

Barres d’outils 
(Ci-dessous) 

Nom des couches 

Panneaux 
Supplémentaires 
(arborescence…) 

Affichage des couches 

Boite à outils 
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QGIS_A04 - Le projet QGZ 
 

La mise en forme des différentes fenêtres, l’ordre de superposition des couches, le choix des 
styles pour les objets cartographiques, le positionnement des étiquettes, la légende etc. sont 
autant d'opérations qu'il est intéressant de sauvegarder pour ne pas avoir à les reproduire à 
chaque ouverture de QGIS. Ces éléments ne sont pas enregistrés dans les couches.  
Le projet de travail (Projet QGIS) permet de sauvegarder une session de travail (format du 
fichier : *.qgz). QGZ est un format compressé qui contient deux fichier (QGD et QGS). Voici 
un exemple de fichier *.qgs ouvert avec un éditeur de texte :  
 

 
Pour enregistrer l’état d’avancement du travail dans un projet, aller dans le menu Projet 
>Sauvegarder le projet. 
Le projet est un fichier unique qui ne contient pas de données géographiques. Il renferme 
simplement une série d'instructions qui est donnée à QGIS et qui précise : l’emplacement des 
données utilisées dans la session, l’état des vues (fiche B02), les mises en pages (fiche F01), la 
mise en forme des objets, etc... Plusieurs projets peuvent utiliser les mêmes couches de données 
dans des mises en forme différentes. Le projet contient des instructions sur les couches à utiliser 
(il enregistre le chemin d’accès aux fichiers utilisés, relativement au projet), il est indispensable 
de préserver ces couches telles qu’elles sont lors 
de l'enregistrement du projet. Si, une couche est 
déplacée ou renommée (sans déplacer tout le 
dossier du projet et des couches), QGIS demandera 
où est enregistrée la couche à la prochaine 
ouverture du projet.  
A l’ouverture du logiciel, la partie centrale « vue », 
propose directement l’ouverture des derniers 
projets. 

Paramètres de la vue 

Paramètres, d’affichage, 
de la légende…. 

Etendue de la vue 

Projection des couches 

Projection de la vue 

Propriétés et statut 
des couches 
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QGIS B - Gestion des couches 
 
 
 
 
 
 
La gestion des couches est essentielle pour bien démarrer l’apprentissage du logiciel. 
Bien comprendre comment s’organisent les couches les unes par rapport aux autres et comment 
s’organise l’articulation entre la donnée géographique et la table attributaire qui lui est associée, 
est la base de la compréhension des logiciels SIG. 
 
 
Une gestion approximative des couches peut générer de nombreux problèmes d’analyse, 
affichage… 
 

 
 
 
Liste des fiches : 

QGIS_B01 - Ouverture et fermeture d’une couche 

QGIS_B02 - Gestion visuelle des couches (propriétés du projet et d’une couche) 

QGIS_B03 - Affichage des données attributaires à l’écran 

QGIS_B04 - Connaître et modifier la projection d’une couche 
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QGIS_B01 - Ouverture et fermeture d’une couche 
 
 
 
Ouvrir une couche 
Pour ajouter une couche, aller dans le menu Couche> Gestionnaire des 

sources de données  ou depuis la barre d’outils Couche (fiche A03).  
• Ouvrir une couche locale (ordinateur) type Shp, Tiff… : cf. Ci-dessous 
• Ouvrir des données tabulaires (txt, csv, dbf), GPS… (fiche G01) 
• Ouvrir une couche distante (Web) type WMS, WFS… (fiche G03) 
• Ouvrir une table de base de données PostGIS, SpatiaLite… (fiche G04) 

 
Ouvrir une couche locale (vecteur ou raster) 
Dans le Gestionnaire des sources de données , choisir l’onglet ou 

, puis Type de source : Fichier, et cliquer sur le bouton Parcourir . 
Attention au choix de type de fichier/extension (ne seront visibles que les 
fichiers dont le type est activé) : 
 

Ouvrir une donnée locale

1 - Parcourir les données

Types de vecteurs

R
A
S
T
E
R Types de rasters

V
E
C
T
E
U
R

2 – Choisir le type 
de fichier à ajouter

 
 

Attention : Si le système de projection du fichier à ouvrir n’est pas renseigné, ou s’il est 
différent de celui de la Vue, sans que la projection à la volée soit activée, il se peut que les 
données ne soient pas superposées correctement (se reporter à la fiche B04). 
Il est à noter que les rasters n’aiment pas la projection à la volée et nécessitent souvent de 
travailler dans un système de projection unique et adapté…  
Pour ouvrir une image NON géoréférencée, se reporter à la fiche G02. 
 
Fermer une couche 
Pour fermer une couche présente dans le logiciel, un clic droit sur son nom, puis Supprimer 

 réalise l’action (cela ne supprime pas la couche de l’ordinateur), ou depuis la barre d’outils 
Couche (fiche A03). 
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QGIS_B02 - Gestion visuelle des couches (propriétés du projet et d’une couche) 
 
Propriétés du projet 
La Vue / Projet est l’organisation visuelle de la superposition des couches. 
 

Propriétés de la fenêtre vue

Projection de la vue
La projection de la vue se règle en tout premier lieu, dans le menu Projet >Propriétés du projet 
>SCR ou bouton     , avant d’ajouter des couches!! Par défaut, « Activer la projection à la volée » 

est pas coché; il permet de superposer des couches dont le système de projection est différent 
(lorsqu’il est renseigné).

Projection

Unités
cartographiques

Nom de la vue (nom du projet)

Echelle
de la vue

Vue

Superposition
des couches

Rotation de la vue
Loupe « zoomer »
sans modifier l’échelle

  
 

- La superposition des couches se gère par glissement du nom des couches les uns sur les 
autres. L’ordre de visibilité des couches dans la vue est lié à l’ordre des noms. 

- Les couches visibles dans la vues sont les couches cochées . 
- Les actions du menu Couche ont une incidence sur la couche surlignée en gris (active). 

 

Propriétés d’une couche 
Un clic droit sur le nom de la couche (ou menu Couche), puis Propriétés édite les 
propriétés de couche active : 
 

Information : Résumé d’informations sur la couche 
Source : Modifier l’alias du nom de la couche. Modifier la projection de la couche 
Symbologie : Modifier le rendu de la couche, sa transparence 
Étiquettes : Étiqueter les entités en fonction d’un champ présent dans la table attributaire 
Diagrammes : Ajouter des diagrammes en bâton / camemberts sur la couche 
Vue 3D : Créer une vue 3D à l’aide d’un champ d’altitude (z) 
Champs : Paramétrer les champs de la table attributaire 
Formulaire d’attributs : Paramétrer les formulaires de saisie de données (contenus des 
champs) 
Jointures : Créer des liaisons entre attributs de tables (association de couches) 
Stockage auxiliaire : Stocker des données hors de la couche (rotation d’étiquettes…) 
Actions : Lancer des scripts sur la couche 
Infobulles : Information à afficher dans les infobulles 
Rendu : Simplifier le rendu visuel 
Variables : Variables d’environnement précises jusqu’à la couche 
Métadonnées : Lire les caractéristiques de la couche (emplacement, projection…) 
Dépendances : Supprimer les caches de couches dépendantes lors de modifications 
Légende : Ajouter des éléments accessibles depuis le panneau couche (ex. : barre de 
transparence) 
QGIS Server : Informations (titre, résumé, métadonnées) qui seront automatiquement 
transmises au serveur QGIS 
Numérisation : Vérification de la topologie (superposition, trous …) 
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QGIS_B03 - Affichage des données attributaires à l’écran 
 
Dans la vue, à partir du 
menu Couche (ou clic-droit 
sur le nom de la couche ou 
depuis la barre d’outil 
Couches - Fiche A03), 
sélectionner Ouvrir la table 
d’attributs pour afficher les 
données attributaires d’une 
couche.  
La couche doit être 
ACTIVE (surlignée en gris). 
 

Lorsque l’on sélectionne 
une entité sur la vue, à 
l’aide de l’outil Sélection du 
menu Couche (ou depuis la 
barre d’outils - fiche A03), 
la ligne correspondante à 
l’entité est sélectionnée dans 
la table (et inversement).  
Le nombre d’entités 
sélectionnées est inscrit dans l’entête de la table attributaire. 
 

Les outils de la Table attributaire (disponibles depuis une table attributaire est ouverte) : 

• Outils de sélection :  
Lorsqu’une sélection est activée par sélection sur la carte ou sélection d’une entité (simple clic sur une 
ligne) ou plusieurs lignes (à l’aide des touches CTRL ou MAJ lors de clics suivants), on retrouve au-
dessus de la table attributaire (respectivement des boutons ci-dessus) : Sélection par expression, Tout 
sélectionner, Inverser la sélection, Désélectionner, Sélectionner les entités en utilisant le 
formulaire, Placer la sélection au début de la table, Centrer la vue sur la sélection, Centrer et 
zoomer la vue à l’échelle de la sélection, Copier et coller la sélection dans/depuis le presse-papier. 
 

• Outils d’édition :  
Lorsque le « stylo » (premier bouton) est activé, soit Basculer en mode édition, les boutons suivants 
(respectivement, Basculer en mode édition multiple, Sauvegarder les modifications, Actualiser les 
modifications, Effacer les entités sélectionnées, Supprimer un champ (une colonne), Ajouter un 
champ/ une colonne, et Ouvrir la calculatrice de champ) sont alors accessibles. 
Le bouton d’actualisation des modifications est utile dans la mesure où le calcul d’une colonne n’affiche 
pas toujours les nouveaux résultats. 
Le clic droit sur une cellule ouvre un menu contextuel (dupliquer, zoom sur l’entité, ouverture du 
formulaire de saisie (identique au bouton en bas à droite de la table attributaire. 
 

• Mise en forme conditionnelle  :  
Améliorer l’affichage de certains champs de la table 
selon des conditions. 
Exemple : Repérer dans la table les noms de régions à surface 
réduite : 
Règle sur le champ NOM puis cliquer sur  
Condition : "surface" < 500  
Réglage : Choisir les couleurs de texte / fond. Ajouter un 
symbole. 
A chaque ouverture de la table, les régions de petite surface seront 
notées selon les conditions réglées. 
 

• Intégrer la table attributaire  :  
Intègre la fenêtre attributaire au logiciel à la place d’une fenêtre séparée contenant les attributs. 

Remarque : la sélection d’une entité sur 

la carte avec l’outil sélection implique la 
sélection des données associées dans la 

table attributaire et inversement.

Lien entre les données graphiques et attributaires
Vue active

Table attributaire

Un clic-droit sur le nom de 

la couche pour Montrer 
dans l’aperçu permet 

d’obtenir une miniature de 

l’étendue de la couche

Si l’aperçu n’est pas affiché : Menu Vue >Panneaux, 

puis cocher Aperçu 
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QGIS_B04 - Connaître et modifier la projection d’une couche 
 
Il est impératif d’œuvrer dans un système de projection unique dans la mesure du possible. 
Les projections sont exprimées dans QGIS selon leur nom et codes EPSG1 correspondants. 
 

Afficher ou renseigner la projection (se gère en amont du travail) 
- Projection du projet : 

Au moment de l’ouverture du projet, donc de la vue, il faut indiquer la projection de ce projet. 
Ceci a une influence sur l’affichage de toutes les couches (cf. encadré fiche B02) : 

 

Voici la même couche, départements de France en Lambert 93, affichée 
selon une vue en L93 à gauche, et selon une vue en WGS 84 à droite. 
 

 

- Projection des couches : 
Il est INDISPENSABLE de connaître le système de projection des couches (cf. métadonnées). 
Par défaut, QGIS applique la projection définie pour la couche. Cependant : 

o Lorsque la projection de la couche est différente de celle de la vue, il faut Activer la 
projection à la volée de la vue (cf. encadré fiche B02). 

o Lorsque la projection de la couche n’est pas renseignée, QGIS applique par défaut la 
projection de la vue. La projection de la couche se renseigne par clic droit sur le nom 
de la couche, puis Définir de SCR d’une couche ou dans les Propriétés de la couche 

(cf. fiche B02), puis  dans l’onglet Source. 
Le renseignement erroné d’une projection peut induire des erreurs visibles ou non visibles 
(calculs de surfaces, croisements de couches…) :  
Exemple de la France ci-contre, représentée en NTF - Lambert Centre France, (au lieu de 
RGF93-L93, comme le spécifient ses métadonnées) : 
 

 

Modifier la projection d’une couche (Reprojeter une couche) 
Par clic-droit sur le nom de la couche, puis Exporter> Sauvegarder les entités sous…  
Une boîte de dialogue de copie de la couche (création d’une nouvelle couche) apparaît : 
 
 
 

 
 
 
 
 
 
 
 
 
 
NB. : En cas de reprojection Française, préférer les codes IGNF (rechercher dans (1) le code désiré) au lieu de 
EPSG, pour la couche de départ et pour la couche d’arrivée. Ces codes utilisent la grille centimétrique de l’IGN 
plus précise pour la reprojection. 

                                                
1 Codes EPSG utiles à connaître (http://www.epsg.org/) utilisés dans les logiciels : 
2154 : RGF93 Lambert 93 ;  4326 : WGS84 world geographic 2D ; 
27571 : NTF Lambert zone I ; 27572 : NTF Lambert zone II ;  27573 : NTF Lambert zone III ;  27574 : NTF Lambert zone IV ; 
 

NB : Le menu Vecteur> Outils de gestion de données offre aussi la possibilité de modifier la projection d’une couche 
(Exporter vers une nouvelle projection). Le menu Raster> Projection offre des options de projections pour les rasters. 

1 – Rechercher le 
code désiré ou partie 
du nom 

2 – Sélectionner la 
projection correspondante 

3 – Valider 
la projection 
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QGIS_C - Structure des couches 
 
 
 
 
 
 
La création d’une couche se fait en trois temps. 
Il faut d’abord créer la structure de la couche et bien réfléchir aux informations qu’elle doit 
contenir. Il faut ensuite créer les entités graphiques. Enfin, il faut remplir la table attributaire en 
respectant bien le lien avec la donnée géographique. 
 
 
 
 
Liste des fiches : 

QGIS_C01 - Création d’une couche 

QGIS_C02 - Éditer des données 

QGIS_C03 - Création de champs attributaires 

QGIS_C04 - Création d’objets graphiques 

QGIS_C05 - Modification d’objets graphiques (objets) 

QGIS_C06 - Modification d’objets sémantiques (attributs) 
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QGIS_C01 - Création d’une couche 
 
La création d’une couche doit être précédée d’une étape de réflexion sur la modélisation du 
phénomène à intégrer dans le SIG. Il s’agit d’un aspect fondamental qui permettra une 
utilisation rationnelle et aisée du SIG : Une étape à ne pas négliger. 
 

Tous les objets d’une même couche doivent être du même type géographique (points OU 
lignes OU polygones). Chaque objet géographique stocké dans une couche est doté d’un certain 
nombre d’attributs (ou champs), qui sont définis lors de la création de la couche, puis 
modifiables lors de la modification de la structure de la couche. 
 

Créer une couche 
A partir du menu Couche, choisir Créer une couche (choisir shapefile par défaut si aucune 
base de données ou couche virtuelle n’est utilisée) : 

 
La procédure s’exécute dans cet ordre : 

• Indiquer l’emplacement et le nom du fichier  
• Indiquer l’encodage2 des caractères (UTF-8 de préférence) 
• Choisir le type d’entités à créer (point, ligne ou polygone) 
• Indiquer le système de projection  
• Créer les champs attributaires / colonnes. Le champ est ajouté uniquement avec le 

bouton Ajouter à la liste des champs. Il est possible de créer des champs 
ultérieurement (cf. fiche C03). 

 

Création d’une couche

Type d’entités 

de la couche

Liste des 
champs ajoutés

1 - Entités et Champs

2 – Projection !

Enregistrement

Chemin et nom d’enregistrement de la couche

Projection de la nouvelle couche

 Par défaut, celle du projet ou renseignée !

 Les actions par défaut se modifient dans Préférences 

>Options, puis SCR pour les actions sur les projections

Créer un champ

-Texte
-Entier

-Décimal

-Date

 
 

La couche vierge créée est automatiquement ajoutée à la Vue. Son nom est noté dans la table 
des matières de la vue, au-dessus de la dernière couche active (surlignée en gris). 
Pour modifier une couche créée, rendre la couche éditable (fiche C02) ; créer ensuite des entités 
(fiche C04) et remplir les champs correspondants aux entités créées (fiche C06).  

                                                
2 L’encodage bien paramétré évite les caractères (accents, symboles…) remplacés par des caractères spéciaux. 
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QGIS_C02 - Éditer des données 
 
 
Toute action de modification sur une couche, que ce soit au niveau de sa structure, des entités 
ou de la table attributaire passe impérativement par l’activation de l’édition. 
 

Éditer une couche 
La couche à éditer doit être active, c’est-à-dire surlignée en gris (ACTIVE). 
Dans la fenêtre Vue, commencer l’édition à partir du menu Couche >Basculer en mode 
édition, ou par clic-droit sur le nom de la couche (le clic droit sur la couche assure que la bonne 
couche est éditée !). 

Le bouton  est alors enclenché  (gris plus foncé). 
Le nom de la couche ne change pas, les seules modifications sont l’apparition du stylo devant 
le nom de la couche et l’apparition des nœuds dans la vue (si la couche contient des entités !), 
comme le présente l’image ci-dessous : 

 
 
 
 
 

 

L’édition de la structure, des entités ou de la table attributaire peut alors commencer : 
- Dans la vue, les barres d’outils d’édition (outils Créer des entités et Modifier des entités 

– cf. fiche A03) sont maintenant disponibles (ne sont plus grisées). 
- Dans la table attributaire de la couche, les outils de la barre d’outils d’édition (cf. fiche 

B03), sont aussi accessibles. 
 
Terminer l’édition 
Pour arrêter l’édition, procéder de la même façon, menu Couche> Basculer en mode l’édition. 
Ceci a pour effet d’arrêter l’édition de la couche ACTIVE (surlignée en gris !). 
 

NB. : Lorsque l’on termine l’édition d’une couche ou d’une table, QGIS demande 
automatiquement si les modifications apportées doivent être enregistrées. Ceci est très utile en 
cas de d’erreur ou de mauvaise manipulation. 
 

Il est possible de commencer l’édition de plusieurs couches en même temps ; il reste cependant 
recommandé de ne faire qu’une seule chose à la fois ! 
La fenêtre ci-dessous est un exemple de message lors de la fermeture du logiciel ; certaines 
couches ont été modifiées, le logiciel demande si ces modifications sont à conserver :  

 
 

Éditer une table attributaire qui ne possède pas d’entités (dbf, csv…) 
Ouvrir la table à éditer comme une couche vecteur (fiche B01 si besoin) en spécifiant 

, pour voir un fichier dbf par exemple.  
La table est alors accessible dans la liste des couches à gauche de la vue (même 
s’il n’existe aucune vue associée à cette table), avec un pictogramme 
spécifique, comme présenté ci-contre : 
Pour démarrer l’édition, procéder comme pour une couche vectorielle (ci-dessus). 
Depuis la table attributaire, les outils d’édition (cf. fiche B03), sont alors accessibles. 
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QGIS_C03 - Création de champs attributaires 
 
Créer un champ / une colonne 
Commencer l’édition de la couche ou de la table (fiche C02), puis afficher cette table. 
Dans la barre d’outil de la Table, choisir l’outil Ajouter un champ (fiche B03) : 
Lors de la création du champ, définir tous les éléments constitutifs de ce champ en fonction 
de son utilisation ultérieure. 

Le Type : une variable ‘nombre’ 
peut être qualitative, donc créée en 
‘texte’ pour des raisons d’analyse 
(ex. : codes INSEE/numéros de 
départements…), alors que d’autres 
seront utilisés en ‘nombre décimal’ 
pour la symbologie (surface) ou 
‘nombre entier’ (population…). 
La Longueur de champ : longueur 
de 50 inutile pour les données 
cadrées (INSEE, surface…), par 
contre pour des noms de communes, 
cela semble plus indiqué. 
La précision sera fonction de la 
donnée. Une surface théorique 
calculée avec le SIG n’implique pas 
8 chiffres après la virgule ! 

 
Renommer / supprimer un champ 
La modification de la 
structure de la table 
attributaire d’une couche 
est à éviter : l’ajout ou le 
retrait de champs peut 
altérer la table. Il est donc 
important de vérifier les 
données attributaires après 
ce type d’intervention.  
L’onglet Champs des 
Propriétés de la couche 
(cf. fiche B02) offre aussi 
la possibilité d’insérer / 
supprimer un champ. 
 

Il est possible de renommer un champ depuis cet onglet en double-cliquant sur son nom, 
toujours lorsque le mode édition est activé. 
 
Outils complémentaires 
Activer l’extension si besoin (cf. fiche A01). 
Des outils de gestion des champs sont disponibles au 
travers de la boite à outil de géotraitement. Activer la 
boite à outils depuis le menu Traitements >Boite à 
outils : . Dans l’arborescence, déplier 
Géotraitements QGIS, puis Table vecteur pour 
bénéficier des outils ci-contre. 

Gestion des champs attributaires

-longueur de texte, du nombre,

-nombre de décimales…

Nom du champ
Sans espace ni

caractères 
spéciaux

3 – Type de champ

1 – Rendre la table éditable

2 – Ajouter
un champ

4 – Propriétés 
du champ

Si une longueur de champ est 

trop courte, la valeur du champ 
sera tronquée!
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QGIS_C04 - Création d’objets graphiques 
 
 
 
La couche sur laquelle il faut créer des entités doit être présente sur la vue (soit par ajout de 
couche -fiche B01- soit par création d’une nouvelle couche -fiche C01-). 
Rendre la couche éditable (fiche C02) si elle ne l’est pas. 
 
Numérisation d’une entité 
Attention ! Pour utiliser les outils d’édition sur la couche éditable, la couche concernée doit être 
active (surlignée en gris). 
Utiliser la barre d’outils Editer /Créer des entités (fiche A03) pour ajouter des entités. Selon 
le type d’entité de la couche, l’outil Créer est différent : 

 Créer un polygone 

 Créer une ligne 

 Créer un point 
 
Sélectionner l’outil, puis cliquer (un simple clic gauche par nœud ou point) ; pour terminer une 
construction (ligne ou polygone), faire un clic-droit (le clic droit ne créé pas de nœud 
supplémentaire). 
A la fin de la construction, une boite de dialogue apparaît automatiquement pour permettre de 
renseigner les attributs de l’entité fraichement créée : 
 

 
Cliquer sur OK pour confirmer la création, ou sur 
Annuler pour supprimer la construction si besoin. 
Cette fenêtre est activée automatiquement à chaque 
entité créée ; pour la désactiver, aller dans le menu 
Préférences> Options, puis, sous l’onglet 
Numérisation, cocher Supprimer les fenêtres 
d’avertissement… 
 

 
 
 
NB. : Pour créer des entités parfaitement synchrones / superposées (limite commune, nœuds 
communs…) se reporter à la topologie de la fiche C05. 
 
Lorsque la création des entités est terminée, choisir de Terminer l’édition (fiche C02) et 
sauvegarder le travail. 
 
 
Suppression d’une entité 
L’opération consiste à sélectionner une entité sur la couche et à la supprimer. Une fois qu’elle 

est sélectionnée avec la flèche de sélection  de la barre d’outils Couche, appuyer sur l’outil 

 pour la supprimer ou touche Suppr du clavier. La couche doit être modifiable. 
Pour supprimer plusieurs enregistrements, utiliser ctrl pendant la sélection. 
La fiche A3 recense tous les outils de numérisation et de numérisation avancée. 
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QGIS_C05 - Modification d’objets graphiques (objets) 
 
La modification d’un objet d’une couche requiert que la couche soit modifiable (fiche C02). 
Quitter l’éditeur, en enregistrant les modifications une fois le travail fini ! 
 

Modification 
Les outils de création et de modification sont disponibles depuis les barres d’outils Editer (détails 
des barres sur la fiche A03). Si elles ne sont pas visibles, elles sont disponibles depuis le menu Vue 
>Barres d’outils >Numérisation / Numérisation avancée. 
Depuis la barre de création des entités (Numérisation), on peut librement créer, déplacer, dupliquer 
ou supprimer des entités (fiche C04).  
Depuis la barre de modification des entités (Numérisation avancée), on peut remodeler, créer / 
supprimer / fusionner des parties d’entités. 
Les entités doivent être préalablement sélectionnées – fiche D02 si besoin. 
 

L’outil Activer les outils de numérisation avancée affiche le panneau 
ci-contre, pour construire des entités selon des angles précis (angle 

défini, perpendiculaire ou parallèle). 
 

Nœuds 
L’outil de nœud  permet de déplacer les nœuds. Un premier clic sur le nœud fait 
apparaitre tous les nœuds de l’entité (en rouge). Un clic sur un nœud le fait apparaître en 
bleu , un clic-glissé le déplace. Un clic sur un segment sélectionne les deux 
nœuds d’extrémité (en bleu) ; un clic-glissé déplace ce segment. 
 

Topologie 
A partir du menu Projet > Options d’accrochage 
(environnement de capture ci-contre) active 
l’accrochage pour la couche actuelle, certaines ou 
toutes couches ouvertes. Choisir la Tolérance 
d’accrochage (distance minimum où la souris 
« glissera » automatiquement vers un sommet ou un 
segment existant – mettre 20 pixels pour avoir un 
aperçu). Lors de la saisie d’une nouvelle entité (en rouge lors de l’édition), à l’approche d’une entité 
existante pour laquelle l’accrochage est activé, la nouvelle entité vient se coller en fonction de la 
tolérance d’accrochage. Les nœuds superposés sont alors strictement au même emplacement ! 
 

Règles topologiques et géométriques 
Par défaut, il est possible d’établir des règles topologiques pour une couche donnée (clic-droit, 
Propriétés, puis onglet Numérisation), telles que supprimer les sommets/points en double, 
vérifier la géométrie, ou empêcher la superposition d’entités ou les trous lors de l’édition. 
 

Les deux extensions ci-dessous offrent d’autres options (activer les extensions cf. fiche A01) 
Le menu Vecteur > Vérificateur de topologie ouvre le Panneau 
vérificateur de topologie où l’on fixe les règles de superposition. 
Exemple : empêcher la superposition entre polygones : 
1 – Depuis le panneau, appuyer sur paramètres  puis ajouter la règle : 
« Ne doit pas se superposer » pour la couche concernée. Créer ensuite un 
polygone qui se superpose à un autre. 

2 -  Dans le panneau, cliquer sur Valider . Les erreurs 
de topologie s’affichent en rouge dans la vue et dans le 
panneau vérificateur.  
 

Le menu Vecteur > Vérificateur de géométries 
ouvre la fenêtre d’outils supplémentaires 
(micropolygones, autointersections, multiparties, 
nœuds dupliqués, trous…) 

1 

2 
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QGIS_C06 - Modification d’objets sémantiques (attributs) 
 
La modification des données attributaires se fait en concordance avec les objets graphiques qui 
leurs sont liés. Lors d’une modification (ou d’une création) des données attributaires, il faut 
sélectionner l’entité sur la carte pour savoir à quelle ligne de la table correspond cette entité 
(fiche B03). 
La sélection de l’objet sur la carte se matérialise par un jaune fluo  (couleur modifiable dans 
les Propriétés du projet, onglet Général). Dans la table correspondante, la sélection se 
remarque surligné (gris foncé ou bleu selon les versions). La sélection de l’objet entraîne la 
sélection de la ligne dans la table, et inversement. 
 

Modification d’une cellule (pour une ligne ciblée) 
Pour mettre une table attributaire à jour, Basculer en mode édition (cf. fiche C02 si besoin), 
Ouvrir la table d’attributs  (fiche B03 si besoin) puis changer les données en cliquant sur 
un enregistrement à modifier (directement le contenu d’une cellule). Lorsque les manipulations 
sont terminées, Terminer l’édition. 
 

Calcul d’un champ (même cellule pour plusieurs lignes simultanément) 
De même, Basculer en mode édition, Ouvrir la table d’attributs . 
Pour calculer des données d’une colonne entière / champ il faut sélectionner l’outil 
Calculatrice de champ  depuis les outils de la table attributaire (fiche B03 si besoin). Une 
boîte de dialogue apparaît où il est possible de calculer les champs selon une expression. 
Si des lignes sont sélectionnées, la case permettant de ne mettre à jour que la sélection sera 
cochée par défaut ! 
 

Calcul de champ attributaire/ colonne
Création d’objets graphiques
La numérisation des objets se fait
à l’écran sur la couche éditable

Tapez 

l’expression 

ici

1 – Choix de la colonne à mettre à jour, ou choix 
de création d’une nouvelle colonne

Fonctions
de calculs 

et champs

2 - Calcul uniquement pour la 
sélection ou toute le entités

3 - Calcul du champ

Aide aux fonctions

ou

 
 

Exemple : Calcul des coordonnées X et Y et de la géométrie (périmètre, aire) 
Dans la calculatrice de champ, pour calculer l’aire, appuyer sur Géométrie> $Area, il apparaît 
dans la zone de calcul (valable pour des polygones). Longueur est actif pour des lignes). 
Choisir Géométrie> $x, et Géométrie> $y pour les coordonnées X ou Y. 
Le menu Vecteur > Outils de géométrie> Ajouter les attributs de géométrie permet 
d’ajouter directement les colonnes de géométrie (création d’une nouvelle couche) 
Les ' (guillemets simples) sont nécessaires pour les valeurs de chaines de caractères / texte, 
alors que les nombres (entiers, décimaux) sont à saisir directement. 
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QGIS_D - Analyse spatiale 
 
 
 
 
 
 
L’analyse spatiale participe au traitement même des données à partir de requêtes spatiales bien 
définies ou d’actions qui permettent de répondre à un questionnement précis. 
Une requête est une opération qui consiste à interroger une partie de la table de données (ou 
table attributaire). 
Les requêtes peuvent porter aussi bien sur des données attributaires que sur des objets 
géographiques. 
 
 
Liste des fiches : 

QGIS_D01 - Sélection par attributs (requête attributaire) 

QGIS_D02 - Sélection géographique (requête géographique) 

QGIS_D03 - Jointure attributaire/ Jointure spatiale 

QGIS_D04 - Outils d’analyse spatiale : vecteur 

QGIS_D05 - Outils d’analyse spatiale : raster 
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QGIS_D01 - Sélection par attributs (requête attributaire) 
 
La sélection attributaire se fait sur une seule couche et sur un ou plusieurs attributs de cette 
couche (attention, ceci concerne donc la couche active / surlignée en gris) : 
 

Sélection 
La sélection par expression est accessible depuis la table attributaire (fiche B03 si 
besoin) ou de la barre d’outils Couche (fiche A03 si besoin) en cliquant sur le 
bouton . Attention : avec cette Sélection, on observe le résultat de la sélection en 
surbrillance jaune fluo, mais les autres entités sont toujours présentes. Dans ce cas, 
il est possible de désélectionner les entités sélectionnées de la couche active avec 
l’outil Effacer la sélection  de la barre d’outils Couche. 
 

La couche concernée par la sélection 
est la couche ACTIVE

Choix des 
Champs 

et des 

fonctions

Choix des 
Valeurs

connues

Requête finale

Sélection par attributs

1

3

2

Opérateurs 

de sélection

4 : Vérification

Aide
contextuelle

1b

5 : Méthode de sélection  
 

Les valeurs en texte sont à saisir entre guillemets simples ('…'), contrairement aux nombres. 
And :"vrai" lorsque ses deux arguments (les expressions qu'il relie) sont vrais. Un enregistrement doit donc satisfaire ces deux conditions pour 
être sélectionné. 
Or :"vrai" lorsque l'un au moins de ses arguments (les expressions qu'il relie) ou les deux sont vrais. Un enregistrement ne doit donc satisfaire 
qu'une seule de ces deux conditions pour être sélectionné. Il est aussi sélectionné s'il répond aux deux conditions. 
 

Exemple 
Sélectionner les départements qui ont leur chef-lieu dont le X est à moins de 5100m de l’origine (attribut « X ») et n’appartenant pas à la 
Bretagne (attribut « NOM_REGION ») dans la couche ‘deparement.shp’ : 
Couche : DEPARTEMENT.SHP (à activer en gras dans la vue) 
Critères (requête) : X <= 5097 AND NOM_REGION != 'BRETAGNE' 
X et NOM_REGION (noms des colonnes) sont à sélectionner dans le menu champs, <=, != et AND dans les Opérateurs. 5097 et 
'BRETAGNE' peuvent être saisis directement dans Valeurs connues. 
 

Exporter la sélection 
Vérifier que la couche sur laquelle la sélection est réalisée soit bien active (en gras), puis choisir 
le menu Couche> Enregistrer sous… (ou par clic-droit sur le nom de la couche> Exporter). 
Sélectionner « N’enregistrer que les entités sélectionnées ». Déterminer le nom de la couche 
de sortie (le type de fichier et la projection si besoin). 
 

Filtre 
Depuis la vue, choisir le menu Couche ou par clic-droit sur le nom de la couche, choisir 
Filtrer. Entrer l’expression de sélection ; seuls les objets correspondants à la requête 
apparaissent à l’écran ; il est possible d’effacer la sélection à partir du Constructeur de 
requête (filtre) : laisser la partie requête (Expression de filtrage) vide. 
Tant que le filtre reste actif, le logiciel ne considèrera que les entités filtrées ! 
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QGIS_D02 - Sélection géographique (requête géographique) 

 
Sélection manuelle 
Les outils de sélection géographique sont disponibles par la flèche noire à droite de l’outil 
(Sélectionner) de la barre d’outils Attributs (fiche A03) ; une liste de sélections s’affiche pour la 
couche ACTIVE (en gras) :  

A l’aide de l’outil  (ou autre type de sélection), 
cliquer sur l’entité à sélectionner (plusieurs sélections 
en maintenant Ctrl). L’entité sélectionnée apparaît en 
jaune.  
 
Sélection par localisation 
Le menu Vecteur> Outils de 
recherche, offre plusieurs 
sélections, comme des sélections 
aléatoires… 
La sélection la plus utilisée est la 
Sélection par localisation :  
Elle sélectionne des entités d’une couche en fonction 
d’entités d’une autre couche. La syntaxe se monte 
comme une simple phrase à lire. 
Désélectionner les entités sélectionnées de la couche 
active avec l’outil . 
 

Exemple ci-contre : un point est sélectionné en jaune : il « intersecte » les polygones. 
 
Les requêtes possibles sont les suivantes (selon les types de géométries) : 

A

B

B

A

B

Chevauche

Opérateurs de la requête spatiale

A l’intérieur

Est disjoint

A

B

Contient

A

A

B

Touche

+

Intersecte

A

B
B

=

A

Est égal

A

B

Croise

A
B

A est la couche de référence, B est la couche dans laquelle on sélectionne  
 
Exemple : 
Sélectionner les éléments de la couche ‘riviere.shp’ (A), qui intersectent le département du Nord de la couche 
‘departement.shp’(B) : 
Vous devez, dans un premier temps sélectionner, le département du Nord dans la couche ‘departement.shp’ (B) 
(A l’aide d’une sélection simple fiche D01). 
Dans l’interface sélection par localisation, il faut choisir la couche ‘riviere.shp’ (A), puis la couche 
‘departement.shp’ (B) (seule la sélection préalable sera prise en compte dans l’opération si ‘Entité(s) 
sélectionnée(s) uniquement’ est coché). 

Couche de polygones 

lignes et points 

polygones 

Couche de points 
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QGIS_D03 - Jointure attributaire/ Jointure spatiale 
 

Jointure attributaire 
La jointure de tables est généralement utilisée pour adjoindre des attributs supplémentaires à la 
table d’une couche géographique (couche de départ). Pour joindre deux tables, le type des 
données du champ joint doit être identique entre les tables (nombres, chaînes…). 
Dans les Propriétés de la 
couche, depuis l’onglet Jointure 

, ajouter une nouvelle jointure 
à l’aide du bouton . 
Renseigner la couche ou table à 
joindre à la couche ciblée, puis le 
champ de jointure pour cette 
table attributaire. Entrer ensuite 
le champ de jointure de la couche 
d’origine ( !! Un champ de 
jointure peut porter un nom 
différent dans les tables). 
Ce sont les attributs de la table 
jointe qui viendront se greffer 
sur ceux de la table de départ.  
 
 

Il est possible de rendre la jointure éditable, sélectionner 
seulement les champs utiles à la table jointe, appliquer un 
préfixe pour identifier les champs de jointure (vide pour 
aucun préfixe), en cochant les cases correspondantes. 
 

Lorsqu’il n’y a pas de correspondance de champ pour la table d’origine, des valeurs nulles 
seront attribuées aux champs joints : 
 

 
 
 
 
 

Exemple : 
Vous disposez d’une couche ‘comm.shp’ représentant le contour des communes ; la table attributaire de cette couche ne contient que le code 
INSEE de chaque commune (nommé IDINSEE). Vous disposez, d’autre part, d’une table attributaire ‘comm_attr’ (sans données graphiques) 
contenant le nombre d’habitants (attribut « hab ») et d’autres champs pour chaque code INSEE ; ce dernier s’intitule CODE dans la table. 
1. Joindre la couche comm_attr ; 2. Joindre le champ : CODE ; 3. Champ ciblé : IDINSEE 

 
Jointure spatiale 
Pour opérer une jointure spatiale (selon la superposition 
des objets) ouvrir Joindre les attributs par localisation 
du menu Vecteur> Outils de gestion de données. 
Sélectionner la Couche d’entrée (1) qui contiendra les 
objets du Fichier de sortie (4), puis la Couche à joindre 
(2) qui contiendra les attributs joints. 
Il est possible de paramétrer le type de requête (3) de la 
jointure– détails des requêtes sur la fiche D02, et de créer 
soit une seule entité, soit plusieurs entités par élément 
joint (5). 

Jointure attributaire 1 : Couche jointe
Possibilité de joindre une 
simple table attributaire (DBF)

Champ 
de jointure
de même 
nature!
(texte, 

nombre…)

2 : Champ de jointure
De la couche jointe

3 : Champ de 
jointure
De la couche d’origine

Il est possible de modifier une jointure préalablement réalisée

(1) 

(2) 

(4) 

Champs de la couche de départ Champs de la couche jointe 

(3) 

(5) 
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QGIS_D04 - Outils d’analyse spatiale : vecteur 
 
 
Les outils d’analyse sont nombreux, il convient de réfléchir à la finalité du travail avant de se 
lancer dans les modifications. Les outils d’analyses sont dans le menu Vecteur> Outils de 
géotraitement : 

 
Chaque outil est composé d’une interface où il faut renseigner 
deux ou trois éléments. Exemple de l’intersection : 
1.  Couche sur laquelle l’opérateur va agir. 
2.  Couche qui participe à l’opération. 
3.  Couche résultante de l’opération 
 
 

L’opération se réalise sur des couches ouvertes ou non dans QGIS. Selon l’outil des options de 
paramétrages supplémentaires peuvent être disponibles. 

Si une sélection est active sur une des couches qui entre dans l’analyse, l’opérateur réalise 
l’analyse uniquement sur celle-ci ! 

 

Ci-dessous quelques exemples d’outils les utilisés en SIG, présents dans QGIS : 
 

Exemples d’outils d’analyse (Menu Vecteur> Outils de géotraitement)

Couper

Intersection
pour assembler uniquement les portions d’entités qui 
se superposent ou à limite commune

Union
pour assembler les entités qui se superposent

DifférenceTampon

Regrouper
Fusionne des entités selon une colonne spécifiée

 
 

Les outils d’analyse et des outils supplémentaires sont intégrés dans QGIS au travers de la Boite 
à outils de traitements. 
Activer la boite, depuis le menu Traitements >Boite à outils : . Dans 
l’arborescence, déplier pour bénéficier des outils. Activer l’extension si nécessaire (fiche A03).
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QGIS_D05 - Outils d’analyse spatiale : raster 
 
Les outils d’analyse rasters sont centrés sur l’analyse du maillage du territoire (ceci est lié à la 
nature du raster) ; il convient de réfléchir à la finalité du travail et de connaître lesdites analyses 
avant de se lancer dans les analyses. Les outils d’analyses sont dans le menu Raster. 
 
 
Calculatrice raster 
Le menu Raster > Calculatrice Raster lance un outil 
très puissant qui permet de paramétrer des opérations 
et croiser des rasters. 
 
Exemple : au Kenya, la relation entre l’évaporation annuelle moyenne (E0) et 
l’altitude est la suivante (Studies of evaporation in Kenya, EAAFRO, Nairobi, 
1968) : E0 (mm) = 2422 – (0.109 x altitude (pieds)) 
En disposant du raster MNT nommé MNT_100M@1 de la zone considérée, il est 
aisé de créer le raster des températures à l’aide de la Calculatrice Raster, en 
inscrivant l’expression de la calcultatrice raster comme suit : 
2422 - (0.019 * "MNT_100M@1") 

 
Analyse d’altitude / élévation 

Les rasters d’altitude (MNT : modèle numérique de terrain), permettent 
de déterminer directement (par dérivée) la pente, l’exposition, 
l’ombrage… d’un terrain. 
Les outils sont disponibles depuis le menu Raster > Analyse. Ou du 
menu Traitement> Boite à outils> GDAL. 

Toutes ces analyses nécessitent un MNT au format raster en entrée. 
Les MNT déterminent les points les plus hauts, les plus bas, les sens d’écoulements donc les 
bassins versants. L’analyse poussée des MNT est possible au travers du plugin GRASS et de 
ses traitements disponibles depuis le menu Traitement> Boite à outils> GRASS. 
 
Interpolation automatique 

L’interpolation permet de générer une donnée continue en raster, à 
partir d’une donnée de relevés ponctuels sur le territoire (température, 
altitude, précipitation…).  

Les algorithmes d’interpolation proposés par QGIS (ci-contre) sont accessibles depuis le menu 
Raster > Analyse >. D’autres méthodes telles que le Spline / krigeage / TIN sont accessibles 
depuis le menu Traitement > Boite à outils (Interpolation / GRASS / SAGA). 
 
Le choix de la méthode dépend du type de données et de la distribution spatiale des points. 

Exemple de trois interpolations : 
L'interpolation IDW (Inverse distance weighted) détermine la 
valeur des cellules en calculant une moyenne pondérée à partir des 
valeurs des points du voisinage. Il est impossible de créer des crêtes 
ou vallées si les valeurs nécessaires ne sont pas présentes dans la 
donnée de départ. Si les données d'entrée sont clairsemées ou 
inégales, le résultat obtenu ne sera pas vraiment représentatif. 
La méthode d'interpolation Spline consiste à faire passer une ligne 
par les points de voisinage tout en minimisant la courbure de la 
surface. Le voisinage est défini par les points les plus proches. Cette 
méthode est adaptée aux surfaces sur lesquelles les variations sont 
peu importantes. La méthode Spline peut donner des résultats 
incorrects lorsque les variations sont importantes sur une distance 
horizontale courte car elle peut se traduire par une surestimation ou 
une sous-estimation de la valeur. 
Le krigeage est la première méthode à prendre en considération la 
corrélation spatiale (appréciation graphique de la variance en 
fonction de la distance entre les données). L'intérêt d'une telle 
méthode est l'estimation des valeurs et le calcul de l'erreur de 
prédiction. 

IDW

KRIGEAGE

SPLINE
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QGIS_E - Analyse thématique/Sémiologie/Symbologie 
 
 
 
 
 
 
L’analyse thématique met en évidence un ou plusieurs phénomènes de la carte et participe 
grandement au rendu final d’une carte. Elle joue un rôle dans la perception de la carte par les 
différents interlocuteurs.  
Il est donc indispensable de prendre du recul pour voir si le rendu de l’information est fidèle à 
ce qui devait être mis en avant. Il est aussi indispensable que l’information soit claire et non 
noyée dans une masse d’informations inutiles. 
 
 
 
 
Liste des fiches : 

QGIS_E01 - Symbologie/ Affichage simple des entités 

QGIS_E02 - Analyse thématique/ Affichage avancé des entités 

QGIS_E03 - Etiquetage des entités 
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QGIS_E01 - Symbologie/ Affichage simple des entités 
 
Modifier toutes les entités d’une couche 
Cette étape est importante lors de la manipulation des données, car elle gère le rendu visuel de la 
superposition des couches. C’est dans ces propriétés que l’on peut rendre transparent l’intérieur des 
entités d’une couche pour voir les couches du dessous. 
 
Double-cliquer sur la couche ou faites un clic-droit pour afficher les Propriétés de la couche (fiche B02 
si besoin – propriétés d’une couche), puis sélectionner l’onglet Symbologie (1). 
S’assurer que le premier bouton de l’onglet soit sur affichage simple : Symbole unique (2). 
Quel que soit le type d’entité (point ligne ou polygone), il est possible de modifier le fond et la couleur 
des symboles, à l’aide de la partie Couches de symboles (3). 
 

Changer le figuré unique de toutes les entités de la couche

Types d’entités
(fill)

Texture
Couleur

(1) style (2) Symbole unique

Options 
liées au 
type d’entité

(3)

Transparence

(exemple
pour les 
points)

Rendu final

 
 

Le type d’options est fonction du type d’entités (polygones, lignes, points) 

Le Gestionnaire de symboles du bouton  permet de changer plus d’options dans 
l’affichage des entités de la couche, et de créer des symboles personnalisés. 
 

La transparence générale de la couche se gère à l’aide d’une 
barre de progression présente en bas de la boite de dialogue, 
mais chaque élément de symbole possède sa propre variation de transparence si besoin. 
 

En bas de la boite de dialogue, il est possible d’agir sur le Mode de fusion des couches, (éclaircissement 
/ assombrissement), pour un meilleur rendu graphique. 
 

Si un champ de la table attributaire contient les valeurs nécessaires à la 
caractérisation de la symbologie des entités (couleur de fond, largeur de 

bordure…), il est possible de l’appliquer en cliquant sur le symbole  situé à 
côté de l’option concernée. 
 
L’ouverture répétée des propriétés de la couche pour « tester » 
différents affichages de la couche peut désormais s’éviter en 
appuyant sur le bouton ouvrir le panneau de style de couche 
présent au-dessus de l’arborescence des couches qui ouvre un 
panneau de mise à jour en direct.  
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QGIS_E02 - Analyse thématique/ Affichage avancé des entités 
 
L’analyse thématique a pour objectif principal de mettre en forme les données à afficher sur une carte. 
Elle répond aux règles principales de la sémiologie graphique. Se reporter à ces règles pour connaître 
les différents types d’analyses et/ou méthodes de classification des données. 
 

Représentations selon les types de données 
Dans les Propriétés de la couche, sélectionner l’onglet Symbologie. 
Dans la partie supérieure de la boîte de dialogue, sélectionner l’analyse thématique 
(Type de légende) la plus appropriée à l’affichage des données. Se reporter aux 
règles de la sémiologie graphique pour adapter l’analyse. 
Utiliser l’affichage Catégorisé sur une palette de couleurs distinctes (!) pour les 
valeurs qualitatives et Gradué pour les valeurs quantitatives ordonnées (variables 
continues vers des variables discrètes). Les valeurs quantitatives absolues (variables brutes absolues) 
seront représentées par un affichage de symboles proportionnels sur leur centroïde. 

- Carte de chaleur : représenter une densité de points sous forme de raster.  
- Ensemble de règles : combiner les règles de représentation. 
- Déplacement de points : déplacer légèrement les points qui se superposent. 
- Polygones inversés : appliquer une symbologie à l’espace non occupé par des polygones. 
-  : Aucun symbole ne sera affiché pour la couche. 
-  : Utilisation de la symbologie Grass. 

 

Valeurs quantitatives ordonnées 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Après un changement de type d’analyse, il est impératif d’appuyer sur le bouton . 
Il est possible de rentrer les classes manuellement (5). 
Remarque : Les couches sont enregistrées en shapefile (*.shp). Les symbologies produites avec Sauvegarder le style sont en *.qml.  
 

La classification de données quantitatives n’est pas le fruit du hasard ! L’histogramme de répartition des 
données offre la visualisation de la fréquence de distribution d’un champ donné avant d’entamer une 
classification des données. Les règles générales sont les suivantes : 

- Symétrique : Méthode de la moyenne et de l’écart-type 
- Dissymétrique : Effectifs égaux (quantiles) ou ruptures naturelles 
- Uniforme : Amplitude égale (Intervalles égaux) 
 

L’histogramme est disponible depuis l’onglet 
Histogramme, en milieu de fenêtre, en 
complément de l’onglet Classes (5). Une 
classification (même manuelle) doit être justifiée. 
 
Exemple 
Pour représenter la densité de population d’une couche de polygones : 
Dans la partie haute de l’onglet Style, sélectionnez Gradué puis Intervalles égaux (ou autre mode de calcul des classes selon répartition de 
l’histogramme !). Dans la partie Colonne, au centre de la boîte de dialogue, choisissez le champ DENSITE, puis le nombre de classes. Vous 
pouvez changer les couleurs des plages ainsi que la légende qui apparaîtra dans la partie droite de la boîte de dialogue. 

Importation de 
la symbologie  

Type d’analyse 
thématique 

(2) 

Nombre de 
classes 

(3) 

Etiquette de 
légende et 
précision 

(6) 

Champ de 
classement 

(1) 

Classement 
des valeurs 

(5) 

Couleur de 
classement 

(4) 
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QGIS_E03 – Etiquetage des entités 
 
Etiquettes 
Dans les propriétés de la couche (fiche B02 si besoin – propriétés d’une couche) sélectionner 
l’onglet Etiquettes (ou menu Couche> Etiquetage). 
S’assurer que l’étiquetage des entités est actif en sélectionnant en premier lieu « Monter les 
étiquettes de cette couche :  
 
S’assurer que le champ Etiqueter avec est bien celui qui contient les étiquettes que l’on veut 
voir affichées ! 

Le bouton , en haut de la fenêtre permet de paramétrer les options d’étiquetage en fonction 
d’autres champs de la table attributaire. 
 
L’étiquetage se paramètre en premier lieu par le Champ de l’étiquette (apparait sur la carte 
finale), la Taille de police, la Police, la Hauteur et la Couleur. 

 
La mise en page de 

l’étiquette (retour à la 
ligne…) 

 
La création d’un halo 

autour de l’étiquette 
(ombrage). 

 
Création d’un fond 

d’étiquette et décalage 
de l’étiquette pour 

éviter les 
chevauchements. 

 
Le placement de 

l’étiquette par rapport 
à l’entité. 

 
Les niveaux de zoom 

pour lesquels les 
étiquettes seront 

visibles. 
 

Enfin, il est possible d’enregistrer les paramètres de l’étiquetage :  
 
Si un champ de la table attributaire contient les valeurs nécessaires à la 
caractérisation d’un élément de représentation du texte (couleur de fond, 
espacement des caractères…), il est possible de l’appliquer en cliquant 
sur le symbole  situé à côté de l’option concernée. 
 
Paramétrage manuel des étiquettes 
Il est possible de déplacer, retourner, masquer ou paramétrer manuellement chaque étiquette à 
l’aide de la barre d’outils Etiquettes (ci-dessous). Le déplacement / paramétrage sera stocké 
localement dans le projet en cours. 
 

(1) Champ pour l’étiquetage 
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QGIS_F - Mise en page 
 
 
 
 
 
 
La mise en page est l’étape finale du travail. Les étapes de manipulation des données (création, 
analyse spatiale), et de représentation de la symbologie, doivent être terminées pour entamer la 
mise en page. 
Elle consiste à mettre tous les éléments indispensables à une carte. 
La carte doit contenir impérativement : 
Une légende, un titre, l’orientation, l’échelle, les sources, le nom et la date de réalisation. 
 
Les logos et mentions légales ne sont pas superflus, ainsi qu’un texte explicatif pour éviter toute 
mauvaise interprétation de la carte produite. 
 
 
 
Liste des fiches : 

QGIS_F01 - Création d’une mise en page 

QGIS_F02 - Création d’une légende 

QGIS_F03 - Éléments d’une mise en page 

QGIS_F04 - Exportation de la mise en page et Atlas 
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QGIS_F01 - Création d’une mise en page 
 
 
La création d’une mise en page permet d’éditer une carte complète pour l’imprimer ou 
l’exporter. 
Avant de lancer une mise en page cartographique, s’assurer d’avoir adapté la symbologie et les 
étiquettes des couches dans les propriétés de chaque couche (fiches E). 
 
Créer une mise en page 
Lancer une mise en page à partir du 
menu Projet> Nouvelle mise en page :  
 

 
A partir de la fenêtre du composeur, 
adapter la page (depuis le menu Mise en 
page> Paramètres de la page, changer 
la mise en page de paysage (horizontal) 
vers portrait (vertical) si besoin. 
Outils pour se déplacer sur la page à 
partir de la barre spécifique et du menu 
Vue :  

 
 
Gérer les éléments :  

Le menu Ajouter un élément permet d’ajouter les éléments de la mise 
en page (détails de chaque élément fiche F03) : 
Les éléments ajoutés depuis ce menu sont des Objets. 
Le cœur de carte, à savoir la Vue, s’ajoute en premier lieu à partir de ce 
menu Ajouter un élément > Ajouter une carte . 
Pour ajouter les éléments indispensables à la carte comme le titre (Texte 

), l’Orientation , l’Échelle , la Légende  (fiche F02) ou un 
logo (Image ), aller dans Ce menu Ajouter un élément et sélectionner 
l’item désiré. 

Les objets ajoutés à la mise en page possèdent plusieurs options spécifiques dans l’onglet 
Propriétés de l’objet (à droite du composeur). Les sous-onglets permettent de choisir le fond, 
le cadre et la transparence de l’objet, les éléments présents dans l’objet.... 
On supprime un objet sélectionné à l’aide de la touche Suppr. 
 

Le menu Eléments permet d’organiser les objets entre eux : 
• Groupement de plusieurs objets 
• Ordre de superposition des objets 
• Verrouiller la position des objets 
• Aligner les objets entre eux (détail fiche F03) 

 
Gérer les mises en page 
Lorsque la carte est terminée, aller dans le menu Mise en page, pour Exporter en image, PDF 
ou SVG (fiche F04). 
 
Depuis la fenêtre Vue / Projet, ne pas oublier d’Enregistrer le projet au fur et à mesure du 
travail (fiche A04 si besoin). Lorsque plusieurs mises en pages sont créées, il est possible de 
les retrouver depuis le menu Projet> Mises en page. 

Nouvelle mise en page vierge 
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QGIS_F02 - Création d’une légende 
 
Une commande spécifique existe pour créer une légende décrivant toutes les informations contenues 
dans la carte. Menu Ajouter un élément> , puis cliquer sur la mise en page pour 
l’insérer. Pour cela, il faut bien évidemment se trouver sur une fenêtre Composeur (fiche F01 si 
besoin). 
L’ajout d’une légende est totalement lié à la vue active qui lui est associée. 

Une fois la légende ajoutée, l’onglet Propriétés de l’objet associé à cette légende 
(partie droite du composeur), propose plusieurs sous-onglets cliquables pour 
paramétrer celle-ci : titre de légende ; ajouter/supprimer/grouper les éléments de la 
légende, les renommer ; format général et police des éléments (titres et couches) ; 
créer la légende en plusieurs colonnes ; changer l’aspect : du fond ou des bordures 
du cadre de légende… 
 

9 – Créer des 
filtres 
d’expressions

Création d’une légende
1 – Propriétés de la 
légende

6 – Renommer 
l’élément de la couche

4 – Réorganiser les 
éléments de légende

3 – Sélectionner 
l’élément de 
légende à 
modifier

2 – Mettre à jour les 
éléments en 
fonction des 
modifications de la 
carte, ou 
réinitialiser toute la 
légende

7 – Afficher le 
nombre d’entités

5 – Créer un groupe 
de couches

8 – Afficher 
uniquement les 
couches visibles

 
La légende sur la fenêtre Carte est dynamique ; elle peut se mettre à jour lors de modifications des 
éléments de la couche (nom, figurés…). Il est conseillé de ne créer la légende qu’après avoir finalisé 
tous les éléments nécessaires à la carte. 
 
Libellés des éléments de légende 
Pour gérer durablement les libellés de la légende, se reporter aux Propriétés (fiche B02 si besoins) de 
la couche concernée. Sous l’onglet Source, modifier le nom de la couche au besoin. Sous l’onglet 
Symbologie des Propriétés de la couche, modifier les libellés de la symbologie des éléments 
(Légende). 
NB. : Les éléments de la légende sont organisés par défaut selon l’ordre d’empilement des couches. 
Celui-ci ne correspond bien souvent pas aux règles de mise en page d’une légende (élément principal 
de la carte en premier, regroupement des éléments de la légende en fonction de leur nature…). 
 
Diagrammes 
Les diagrammes en camembert bénéficient d’une légende paramétrable. Depuis 
les propriétés de la couche, puis l’onglet Diagrammes, le sous onglet Légende, 
offre la possibilité d’afficher : 
- Les éléments qui composent le camembert 
- La variation de taille des 

diagrammes 
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QGIS_F03 - Éléments d’une mise en page 
 

Ajouter une carte/ vue :  
La vue s’ajoute en premier . Elle est liée dynamiquement à la carte créée dans le projet. 
La vue, appelée Carte (lorsqu’elle est insérée dans la mise en page) est paramétrable depuis 
l’onglet Propriété de l’objet à droite du composeur (ces propriétés sont associées à l’objet 
sélectionné sur la mise en page) : 

Mise à jour de l’aperçu et rendu en temps réel ou non (lors de 
modifications de la vue) 
Niveau de zoom de la carte 
Echelles de l’atlas 
Création d’une grille de repérage sur la carte 
Créer un aperçu (carte de localisation) 
… Gestion du cadre de la carte, de la transparence… 

Dans les propriétés principales, il est possible de modifier le SCR de la carte !  
 

Ajouter du texte :  
Cliquer sur  puis sur la carte à l’endroit désiré. Déplacer cet objet  et modifier le texte 
(taille, police, habillage, etc.) dans l’onglet Propriétés de l’objet. 
 

Ajouter une orientation :  
Il est possible d’afficher une simple flèche , ou une image  (plusieurs modèles de flèches 
indiquant le nord sont disponibles dans les images par défaut proposées –si une rotation de la 
vue ajoutée a été exercer, penser à le faire aussi pour la flèche nord !) 
 

Ajouter une échelle graphique : 
L’échelle graphique  est paramétrable dans l’onglet Objet : 
 

 
 
 
 
 
 
 

 
 

Disposer les objets : 
Il est possible de disposer les objets les uns par rapport aux 
autres. Pour cela il faut sélectionner plusieurs objets (à l’aide 
de la touche Maj enfoncée) puis utiliser les outils de la barre 
concernée  ou du menu éléments.  

Il est possible de grouper les éléments  ou les 
verrouiller . 

 
Les outils classiques d’agencement des objets les uns par rapport aux 
autres (avancer un élément, le reculer…) sont également disponibles. 

 
Deux outils  de redistribution automatique (redistribuer les objets les uns par rapport aux 

autres pour éviter les superpositions) et de redimensionnement automatique 
(redimensionner un objet par rapport à la forme d’un 
autre objet) sont désormais disponibles. 

3- Choisir le facteur d’unités 
Exemple : les systèmes de projection sont en mètre ; 

pour un affichage de l’échelle en km, il faut un facteur de 1000 

1- Choisir la carte associée et l’apparence de l’échelle 

2- Choisir l’unité de l’échelle qui sera affichée 

4- Choisir la largeur d’échelle (taille des segments) 
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QGIS_F04 - Exportation de la mise en page et Atlas 
 
 
 
Lorsque la mise en page est terminée, il est possible de l’imprimer (menu 
Mise en page> Imprimer) ou d’exporter cette mise en page (menu Mise 
en page> Exporter au format PDF ou Exporter au format SVG, ou 
Exporter comme image). 
Lors de l’export en image, tous les formats ci-contre sont utilisables : 
 
 

Avant l’export final, il est indispensable d’observer la carte en taille adaptée  qui donne une 
visualisation globale de l’image finale qui sera exportée (ce qui inclut la taille des étiquettes par 
exemple). 
 
Exemple d’impression : 

 
Remarques sur l’exemple : 
QGIS permet d’insérer plusieurs vues 
différentes et de SCR différents sur une carte 
(plan de situation…). Il faut verrouiller les 
cartes déjà présentes (onglet Eléments) 
lorsqu’une carte est terminée. Cependant, si 
une couche doit entrer dans la composition des 
deux visualisations mais avec une symbologie, 
étiquetage différents, il convient alors de 
copier cette couche, afin de pouvoir gérer plus 
facilement les vues séparément. 

Remarques sur le format d’export de la carte : 
- L’export en PDF : L’installation d’un petit logiciel d’impression en images diverses tel 

PDFCreator, disponible gratuitement sur Internet peut contrer ce problème. 
- D’une manière générale, il est préférable d’exporter en PNG lorsque la carte ne contient 

que des vecteurs et en JPG dès qu’il y a des images ou des rasters sur la carte. 
 
Générer un atlas 

Depuis la fenêtre de composition, aller dans le menu 
Vue >Panneaux > Génération d’atlas s’il n’est pas 
activé. 
 
Il est possible de générer un atlas (batteries de cartes 
en fonction d’une couche de polygones). 
Indiquer la couche qui servira de découpage et 
paramétrer la sortie des fichiers. 
 
Au moment de l’impression, il faut choisir un dossier 
de destination au lieu de choisir un nom de fichier. 

 
Exemple : Créer des cartes en fonction des limites de départements. L’atlas génèrera autant de 
cartes qu’il y a de départements, sur leur emprise respective. 
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QGIS_G - Intégration de données externes 
 
 
 
 
 
 
 
 
 
 
 
Liste des fiches : 

QGIS_G01 - Ouverture de données tabulaires (txt, csv, dbf), GPS et autres 

QGIS_G02 - Géoréférencement d’images : Données rasters 

QGIS_G03 - Ouverture de protocoles Internet – WebServices (WMS, WFS…) 

QGIS_G04 – Connexion et gestion de bases de données 
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QGIS_G01 - Ouverture de données tabulaires (txt, csv, dbf), GPS et autres 
 
 
Ouvrir ou exporter des données tabulaires ou données vectorielles externes  
Il est possible d’ouvrir de multiples données, qu’elles soient 
vectorielles ou tabulaires à partir du menu Couche> 
Gestionnaire de sources de données (fiche B01).  
Tous les types de fichiers listés ci-contre sont importables.  
Les fichiers MapInfo (TAB) ou interchangeables MIF/MID 
sont donc accessibles directement. 
 

Les données tabulaires sont des données attributaires ; elles 
ne possèdent pas de données géographiques (pas d’entités !). 
QGIS offre la possibilité d’ouvrir directement des fichiers 
CSV3 ou texte (TXT). Les fichiers s’ouvrent alors tels que 
s’ouvrent des couches (fiche B01). 
Un fichier XLS bien construit peut s’ouvrir directement, 
comme un DBF. 
La table se gère ensuite comme une table attributaire de 
couche géographique classique. 

La table est alors accessible dans la liste 
des couches à gauche de la vue (même 
s’il n’existe aucune vue associée à cette 
table), avec un pictogramme spécifique, 

comme présenté ci-contre : 
 

Attention : les données tabulaires ou vectorielles externes peuvent être en lecture seule. Il faut 
donc enregistrer une copie de ces données pour les rendre modifiables : A partir du menu 
Couche> Sauvegarder sous, lorsque la table est active (surlignée). 
 
Données GPS 
Dans la plupart des cas les systèmes de positionnement par satellites type GPS permettent de récupérer 
des fichiers de points au format ASCII (format texte) ou GPX, à partir du menu Couche> Ajouter 
une couche vecteur (fiche B01). Si les données ne sont pas directement transférables au logiciel SIG 
l’extension Outils GPS (installée par défaut) du menu Vecteur peut aider. 
 
Acquérir des données géographiques à partir de tables attributaires : 
Certaines données ne présentent pas d’objets géographiques mais ceux-ci peuvent être construits si on 
connaît leur localisation en X et en Y.  
La présence de coordonnées X et Y dans les champs de la table va nous permettre de créer pour 
chaque ligne du tableau un point avec les coordonnées correspondantes. 
A partir du menu Couche> Gestionnaire de sources de données puis onglet Texte délimité 
spécifier les données géographiques (X et Y) d’un fichier TXT ou CSV dans l’onglet Définition 
de la géométrie. 
Ne pas oublier de spécifier le système de projection associé aux coordonnées géographiques ! 
Astuce : Pour un fichier autre que CSV/TXT, l’ouvrir classiquement, enregistrer une copie de 
ce fichier en CSV, puis créer les points à partir du fichier CSV créé. 

                                                
3 Le fichier CSV est éditable/créable avec un éditeur de texte. La première ligne doit contenir les champs des 
colonnes, séparés par « ; » (un point-virgule), les lignes suivantes les données, séparées aussi par « ; ». 
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QGIS_G02 - Géoréférencement d’images : Données rasters 
 
 
Ouvrir l’outil 
Inutile d’ouvrir l’image avant de la géoréférencer, utiliser 
l’extension (installée par défaut) Géoréférenceur GDAL du 
menu Raster> Géoréférencer. 
 

Ouvrir l’image 
La partie supérieure contiendra alors l’image, alors que la partie inférieure contiendra la Table 
des points de contrôle (points de géoréférencement).  
Dans la fenêtre Géoréférencer, ouvrir l’image à géoréférencer (Fichier> Ouvrir raster). 
 

Spécifier la projection 
A l’ouverture de l’image, si la fenêtre SCR n’apparaît pas, spécifier le système de projection 
de géoréférencement dans Paramètres> Paramètres de géoréférencement. 
 

Ajouter des points de calage 
Dans la fenêtre Géoréférenceur, pour ajouter un point de 
calage, cliquer d’abord sur l’outil Ajouter un point . 
Une nouvelle fenêtre s’ouvre, permettant deux types de 
géoréférencement.  
 

Type de géoréférencement 
Cas 1 : les coordonnées des points à géoréférencer sont connues 
Entrez-les manuellement dans X et Y. Les coordonnées « image » (pixels) s’ajoutent dans srcX et srcY 
de la partie Table des points de contrôle ; les nouvelles coordonnées dans dstX et dstY. 
 

Cas 2 : la vue active sera utilisée pour caler l’image 
Choisir  au lieu d’entrer manuellement les coordonnées. Le logiciel pointe 
alors la vue courante où il est possible de choisir l’endroit réel auquel correspond le point fraîchement 
choisi. Les srcX et srcY se remplissent automatiquement avec les coordonnées, dans le système de 
projection de la vue en question ! 
 

Lors du géoréférencement, modifier  ou supprimer  le placement d’un point est possible. 
Les outils de zoom classiques sont disponibles pour se déplacer sur la carte. 
 

Spécifier le type de transformation 
Avant de commencer le géoréférencement, indiquer le type de transformation et le Raster de 
sortie dans le menu Paramètres> Paramètres de transformation. 

Type de transformation 
On utilise une transformation affine lorsque l’image à référencé est dans la même projection que l’image de référence 
(4 points suffisent). On utilise les transformations polynomiales lorsque les déformations sont importantes (cartes 
napoléoniennes…). Il faut un minimum de quatre points pour une transformation polynomiale de premier ordre, six 
pour une transformation de second ordre et dix pour une transformation de troisième ordre. 

Remarque : Un grand nombre de points n’améliore pas forcément la qualité du résultat, préférer donc des points 
près de chaque angle de l’image à référencer et quelques points au centre. Ne jamais aligner les points. 

 

Enregistrement du géoréférencement 
Dès que 4 points de calage sont créés (non 
alignés et éloignés du centre de l’image), le 
logiciel calcule le géoréférencement : il 
déplace légèrement les points (dX et dY) et 
affiche l’erreur associée (residual). 
Lorsque ceux-ci sont acceptables (le plus 
faible possible), enregistrer le raster résultant à partir du menu Fichier> Débuter le 
géoréférencement. 
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QGIS_G03 - Ouverture de protocoles Internet – WebServices (WMS, WFS…) 
 
 
Cette page aborde les connexions sur Internet. Si 
l’ordinateur est derrière un Proxy, il est 
indispensable de paramétrer le Proxy dans QGIS, 
depuis le menu Préférences> Options, puis onglet 
Réseau, pour afficher la fenêtre ci-contre, cocher 
Utiliser un proxy pour l’accès Internet, et paramétrer 
ce Proxy. 
Se rapprocher d’un administrateur réseau si besoin. 
 
Les protocoles Internet cartographiques sont des 
services qui diffusent (gratuitement ou non), des 
cartes et données disponibles au travers du logiciel 
SIG. 
L’avantage de ces services est de ne pas devoir 
stocker les données (souvent très lourdes) sur 
l’ordinateur, et de pouvoir superposer ces services à 
des données locales. 
 

QGIS offre la possibilité d’en afficher plusieurs 
d’entre eux (WMS, WFS …). 
Pour accéder à ces services, il suffit de : 

1- Entrer l’adresse Internet du service selon son type (WFS, WMS…) 
2- Choisir les données dont on a besoin 
3- Paramétrer le rendu des données 

 

L’ajout d’une couche WMS est accessible directement depuis le menu Couche> Gestionnaire de 
sources de données, ou panneau Explorateur, puis onglet WMS / WMST. 
 

Connexion aux protocoles de services WMS

1 - Connexion

2 – Choix des données 
disponibles sur le service

3 – Format de restitution

Format d’image

Projection

Choix des couches

 
 

De nombreux services sont accessibles directement dans QGIS ; beaucoup de pages Internet listent ces 
services (exemple : https://sigea.educagri.fr/donnees/serveurs-distants-wms/). 
Un onglet Recherche de serveurs permet d’interroger des services WMS existants sur le Web. 
 

D’autres services tels que l’ajout de couche WFS, WCS… sont accessibles selon la même procédure 
depuis le même menu : choisir le type de service distant (configurer, connecter) et charger les données. 
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QGIS_G04 – Connexion et gestion de bases de données 
 
Les bases de données (BDD) sont un avantage certain dans le stockage et l’automatisation des 
analyses de la donnée. 
Il est possible de se connecter à une BDD locale ou distante ; il s’agit de bien paramétrer la 
connexion. QGIS offre la possibilité de se connecter à de nombreuses bases de données 
géographiques en lecture et écriture des données (il faut connaître les paramètres de connexion 
– à demander à l’administrateur). 
 
PostgreSQL / PostGIS 
PostGIS est l’extension spatiale de 
PostgreSQL. 
Se connecter et ajouter une table 
PostGIS se réalise depuis le menu 
Couche >Gestionnaire de sources 
de données, onglet PostgreSQL. 
Exemple de connexion à une base 
de données locale existante : 

- Nom : choisir un nom 
- Hôte : localhost 
- Port : 5432 
- Base de données : postgres 
- Nom d’utilisateur : postgres 
- Mot de passe : postgres 

 
SpatiaLite 

 
SpatiaLite est l'extension spatiale de Sqlite. Contrairement 
à un SGBD lourd tel que PostgreSQL / PostGIS, une base 
de données SpatiaLite est contenue dans un seul fichier 
facilement « portable ». 
Depuis le menu Couche > Gestionnaire de sources de 
données, onglet SpatiaLite, créer une nouvelle connexion, puis 
parcourir les dossiers jusqu’à l’emplacement du fichier (*.sqlite) 
L’ensemble des couches disponibles s’affiche. 
 

 
Base déconnectée 
L’extension « édition hors connexion » (menu Extension pour charger l’extension, menu Bases 
de données pour l’utiliser), permet de synchroniser une BDD SpatiaLite embarquée (utile lors 
de saisie sur le terrain) à une BDD PostGIS (base centralisée, partagée, administrée où les droits 
d’accès peuvent être gérés). 
 

Gestion des tables et bases 
Lorsque les bases de données sont connectées 
une première fois, elles sont toutes accessibles 
depuis l’extension DB Manager (installée par 
défaut), depuis le menu Bases de données > DB 
Manager pour une gestion centralisée et 
simplifiée des tables disponibles.  

Connexion à une base de données PostgreSQL / PostGIS

2 – Choix des données 
disponibles la base de données

Schéma

1 - Connexion

Table Projection
Clé primaire

Colonne de géométrie
Type de géométrie


